Tet banner

Custom Fields
Re-Envisioned
Support MB Blocks A block without fields does not show the content in Gutenberg

  • Creator
    Topic
  • #30403
    Resolved closemarketing
    Participant

    Hello,
    If I create a block without fields, it shows in editor:
    Enter content in the block settings on the right side.

    We have a lot of blocks that does not need any field, so it should show the content of the block.
    How could avoid that message?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Author
    Replies
  • #30407
    Long Nguyen
    Moderator

    Hi,

    The extension MB Blocks only support rendering the block if it has at least one custom field. I will inform the development team to consider supporting this case.

    #30629
    closemarketing
    Participant

    Ok! Thanks!

    #32358
    PASCAL Hämmerli
    Participant

    Same issue here. It would be nice to be able to create "empty" blocs that are only rendered in front.
    Ideally there would be a 'render_html' parameter to display any html in Gutenberg editor as preview.

    #32543
    Jackky
    Participant

    +1.
    My temporary solution is to use fake field with type "hidden", like this

    [
        'id'   => 'preview_hack',
        'type' => 'hidden',
        'std'  => '1',
    ]
Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.