Custom Fields
Re-Envisioned
Support MB Frontend Submission Adding New Post via Frontend Submission

This topic contains 4 replies, has 2 voices, and was last updated by  Anh Tran 6 months, 3 weeks ago.

  • Creator
    Topic
  • #12417
    Resolved
    @mindspark
    Participant

    Anh –

    I got the frontend form to work which allows me to add new records to a given CPT. In this case, my CPT is Packages.

    here is my shortcode:
    ‘[mb_frontend_form id=”packages” post_fields=”title” submit_button=”Awesome!”]’

    since the shortcode displays all custom fields for my form “packages”, I’m assuming that by entering the data on the front end and also displaying the post title on the same form that all of the custom field data will be saved to a specific record. unfortunately, the custom field data isn’t saving. what I get is a new record in “packages” with the correct title, but none of the custom field data.

    see here: https://snag.gy/xDwMzr.jpg. you can see I have created a new title and entered data in the custom fields.

    but after submitting the form, none of the custom field data is saved to the new record. see here: https://snag.gy/Pr2x0j.jpg

    thoughts?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Author
    Replies
  • #12439

    Anh Tran
    Keymaster

    That’s weird. Can you send me a temporary account to check on your site?

    #12455

    @mindspark
    Participant

    sent the login info.

    page in question – https://siteview.app/projects/restcaps/new/

    #12458

    @mindspark
    Participant

    Anh – I set up a new sample custom field section and added a few fields without the special field ‘Group’. looks like those entries work as expected… so without any deeper testing it looks like the ‘Group’ feature needs some additional work.

    PS – the Group field type is very handy – so I’ll ask that you add it to your work queue and while you are at it – please consider adding a ‘DUPLICATE’ option to the Group field so we can duplicate entire field sections. Also – making it work with Beaver Themer will be a nice option too!!

    #12484

    Anh Tran
    Keymaster

    Hi Neil,

    I’ve checked your site and see you’re using custom table to store custom fields. However, I can’t find the code that create the custom table. Maybe you missed it, and that’s why the custom fields are not saved. Can you please check that again?

    I’ve put the requests for group in my task list. Our team will work on that as soon as we can.

    Update: We have resolved the issue. The problem is that the meta box uses a custom table but there’s no custom table registered. Deselect the checkbox to let meta box saves to custom table fixes the bug.

Viewing 4 replies - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.