Custom Fields
Re-Envisioned
Support Meta Box Builder array_walk error in MB Builder

This topic contains 3 replies, has 3 voices, and was last updated by  pza 4 months, 1 week ago.

  • Creator
    Topic
  • #15152
    Resolved
    Chris
    Participant

    Got errors:
    Warning: array_walk() expects parameter 1 to be array, null given in …/wp-content/plugins/meta-box-builder/src/Upgrade.php on line 84

    Warning: array_walk() expects parameter 1 to be array, null given in …/wp-content/plugins/meta-box-builder/src/Upgrade.php on line 85

    They’re displayed at the top of every post view. Even if it’s really only a warning, it’s not something I want to be showing.

    Was doing lot’s of work with MB today.
    Added advanced attributes – pages were still working.
    Added new fields – pages still working.
    Applied the MB Builder update – pages still working.
    Added two fields via MB Admin Columns. Did not verify pages, since didn’t expect problems.

    However, when I went back to work on adding custom fields to an old post, got the errors above when viewing it.

    I tried undoing everything I had done, in reverse order. The errors persisted. BTW, purged all caches after each thing was undone.
    Started deactivating the extension plugins, one at a time.
    The error didn’t go away until the only thing left was the basic free MetaBox.
    Tried to activate MB Builder to verify it was the problem – and the errors came back.

    Didn’t see any errors on Google F12 diags.

    What do I need to provide you to figure out what happened?
    Right now, Builder and all extensions are disabled, and the work from earlier in the day is still removed.

    thanks,
    chris

Viewing 3 replies - 1 through 3 (of 3 total)
  • Author
    Replies
  • #15153

    Anh Tran
    Keymaster

    Hi Chris,

    Can you send me a temporary admin account to look at? This is a major update of Meta Box Builder and there’s some change in how the plugin stores data. I wrote the Upgrade script to migrate data, but there might be some unexpected bug.

    #15240

    pza
    Participant

    I’m interested if there’s any progress with this, as I have the exact error on a site using the updated MB & AIO plugins.

    #15273

    pza
    Participant

    I restored a backup, and now this seems to be working for me with the latest update.
    I think maybe it was related to a taxonomy field issue mentioned elsewhere. Thanks, and will update here if necessary.

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.