Custom Fields
Re-Envisioned
Support Meta Box Geolocation Autocomplete not working with Google Maps

This topic contains 6 replies, has 2 voices, and was last updated by  Anh Tran 6 months, 3 weeks ago.

  • Creator
    Topic
  • #13398
    Resolved
    —luke—
    Participant

    Hi
    I created a Custom Maps-Field, entered a Google API (places + maps API active). Everything is working exept the autocomplete function. A field-ID is assigned but when tiping into this field I tells me always “No results found”. Also if I hit “find adress” there is no result at all.

    Can you help me further analysing this issue?

    I’m using the latest WordPress with Gutenberg editor integrated.

    Best wishes
    Lukas

Viewing 6 replies - 1 through 6 (of 6 total)
  • Author
    Replies
  • #13437

    Anh Tran
    Keymaster

    Hi Lukas,

    If you see “No results found”, then the autocomplete works. It queries to Google and no results found, it notices you about that.

    Can you try setting the language or the region of the map? It might help to provide some results.

    #13552

    —luke—
    Participant

    Hi Anh
    I’ve already set my language code (German) and also region code (de) but there is always the same result.

    Is there something I can try further?

    Best
    Lukas

    #13556

    Anh Tran
    Keymaster

    Hi Lukas, I’ve just tested again and couldn’t replicate the bug. Here is my video: http://recordit.co/Fx18GnvJLK. Please check the API key or check the console if Google shows any warning/error.

    #13561

    —luke—
    Participant

    Hi Anh
    Indeed there is a error in my console:

    Geocoding Service: This API project is not authorized to use this API. For more information on authentication and Google Maps JavaScript API services please see: https://developers.google.com/maps/documentation/javascript/get-api-key js:58:110

    Kc https://maps.google.com/maps/api/js?key=AIzaSyAiYKhEzoNTshhryov1HwIcqp9JJlBW22E&language=de&libraries=places&ver=4.16.3:58 d https://maps.google.com/maps-api-v3/api/js/36/4/intl/de_ALL/geocoder.js:2 c https://maps.google.com/maps-api-v3/api/js/36/4/intl/de_ALL/common.js:67 <anonym> https://maps.googleapis.com/maps/api/js/GeocodeService.Search?4sd&7sde&9sde&callback=_xdc_._ngmsah&key=AIzaSyAiYKhEzoNTshhryov1HwIcqp9JJlBW22E&token=76138:1 
    

    I checked my API key and it seems ok.

    #13565

    —luke—
    Participant

    Hi Anh
    Issue fixed: I activated Geocoding API and afterwards it was working.

    What I did/checked additionally:
    – Billing enabeled in Google Cloud Services and Project
    – Places API activated
    – Maps JavaScript API deactivated and activated

    #13567

    Anh Tran
    Keymaster

    Oh, that’s right. You need to enable Geocoding API to use the autocomplete feature. I should have mentioned that in the docs!

Viewing 6 replies - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.