Custom Fields
Re-Envisioned
Support Meta Box AIO Blank page on Add/Edit Custom Post Type

  • Creator
    Topic
  • #17654
    Resolved Matt
    Participant

    I had my post types setup and things were working. I’m not sure if it was after I setup a bunch of taxonomies or not that things stopped working.

    I now can’t ADD a new post OR EDIT any of the posts for this specific post types. The pages are completely BLANK. I had three post types setup and two work and the one I’ve been working on the most stopped working. I can edit a page in Elementor (with Switch Editor Loader Method enabled) but I can’t add any new posts.

    wp-admin/post-new.php?post_type=xx
    wp-admin/post.php?post=346&action=edit

    I’ve been working overtime to get this setup and have hit a real wall. I have tried deactivating all plugins but I can’t deactivate MetaBox as my custom post types disappear but have tried all but MetaBox and Elementor and still have same issue.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Author
    Replies
  • #17659
    Matt
    Participant

    I’m not very technical so no idea if its helpful but this shows as error in debug plugin when I try and load the Add/Edit pages:

    Error Reporting on :-
    [2019-12-28 05:31:42]
    Error Number :-
    8
    Error String :-
    Undefined index: id
    Error File :-
    /home/cheesewheel/public_html/wp-content/plugins/meta-box-aio/vendor/meta-box/mb-rest-api/class-mb-rest-api.php
    Error Line :-
    132
    Error Context :-
    object
    capabilities
    edit_post edit_blockread_post read_blockdelete_post delete_blockedit_posts edit_postsedit_others_posts edit_others_postspublish_posts publish_blocksread_private_posts read_private_blocksread edit_postsdelete_posts delete_blocksdelete_private_posts delete_private_blocksdelete_published_posts delete_published_postsdelete_others_posts delete_others_postsedit_private_posts edit_private_blocksedit_published_posts edit_published_postscreate_posts publish_posts
    description hierarchical viewable labels
    name Blockssingular_name Blockadd_new Add Newadd_new_item Add New Blockedit_item Edit Blocknew_item New Blockview_item View Blockview_items View Postssearch_items Search Blocksnot_found No blocks found.not_found_in_trash No blocks found in Trash.parent_item_colon all_items All Blocksarchives All Blocksattributes Post Attributesinsert_into_item Insert into postuploaded_to_this_item Uploaded to this postfeatured_image Featured Imageset_featured_image Set featured imageremove_featured_image Remove featured imageuse_featured_image Use as featured imagefilter_items_list Filter blocks listitems_list_navigation Blocks list navigationitems_list Blocks listitem_published Block published.item_published_privately Block published privately.item_reverted_to_draft Block reverted to draft.item_scheduled Block scheduled.item_updated Block updated.menu_name Blocksname_admin_bar Block
    name Blocksslug wp_blocksupports
    title 1editor 1
    taxonomies Array ( ) rest_base blocks
    meta_boxes Array ( )

    #17663
    Matt
    Participant

    Since I’m in a time crunch and desperate to figure this out to get the site up I tried DELETING all my taxonomies for that POST TYPE. Once I did the Add/Edit page started working again.

    Why are taxonomies causing the pages not to load?

    #17673
    Anh Tran
    Keymaster

    Hi Matt,

    Looks like there’s an error with the taxonomy setup and REST API. However, I couldn’t replicate it on my local site. Can you take a screenshot of taxonomy settings?

    #17684
    Matt
    Participant

    Thanks for checking.

    taxonomy

    #17687
    Matt
    Participant

    So I tried deleting all of them then re-adding them manually. It was the “type” taxonomy that caused the issues. I deleted it, the pages loaded then RECREATED it using same settings as the other taxonomies and it stopped working again once it was created. Something to do with the word type/types?

    Once I changed the name from Types to Styles the issue resolved. Let me know what you think is going on with the word type/types.

    #17717
    Anh Tran
    Keymaster

    Hi Matt,

    I guess the type taxonomy is used somewhere else on your website. Maybe it’s registered by WP or other plugin. In this case, I think you did best: changing its slug makes it unique and works.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.

Newsletter

Subscribe to our newsletter to receive news and tutorials for Meta Box and WordPress.


grid gear info copy caret-up caret-down trash