Custom Fields
Re-Envisioned
Support General Bug: Checkboxes saved in custom table but shown in UI

This topic contains 11 replies, has 3 voices, and was last updated by  Purdue Alumni Association 9 months, 2 weeks ago.

  • Creator
    Topic
  • #11728
    Resolved
    Purdue Alumni Association
    Participant

    I have a custom post type with a set of custom fields. These fields are saving to a custom table.

    Initially when I create a new post all information is saved and displayed correctly on the UI after the page refreshes. If I then change the text in a text area, the checkboxes that were previously checked in the UI are no longer checked. The database still holds the correct information, but for whatever reason it is not being displayed on the UI.

Viewing 10 replies - 1 through 10 (of 11 total)
  • Author
    Replies
  • #11751

    Anh Tran
    Keymaster

    Hi Purdue,

    I’ve re-checked and don’t see that problem. Can you post your code here to test?

    #11758

    Custom Fields:

    https://ghostbin.com/paste/db3h9

    To recreate:
    1. Fill out all the fields for a new benefit.
    2. Save/Publish
    3. The page reloads
    4. All fields have saved successfully and are displayed correctly in the UI
    5. Change the public description of the benefit
    6. Save/Publish
    7. The page reloads
    8. The checkboxes are no longer checked (but the database does still hold the values)

    #11803

    Anh Tran
    Keymaster

    Thanks a lot for your code. I see it doesn’t work with checkbox_list field type. Let me fix and update the plugin.

    #11835

    aaron
    Participant

    Has a fix been added for this? I’m seeing the same issue.

    thanks.

    #11849

    Anh Tran
    Keymaster

    Hi aaron, I’m still working on it. Please be patient.

    #11850

    Anh Tran
    Keymaster

    Hi guys, I’ve just fixed it. Please update MB Custom Table to the latest version. The AIO plugin will be updated later.

    #11854

    aaron
    Participant

    Thank you very much,
    working as expected now.

    +1

    #11855

    I’ll wait until the update is pushed to AIO and confirm then. Thanks, Anh!

    #11873

    Anh Tran
    Keymaster

    AIO has just been released. Please take a look!

    #11880

    I’ve tried to update AIO, but it doesn’t seem to be working. It appears to update successfully (I get a green update box that displays the message: Updated!) but when I reload the page, the plugin still has the old version number and option to “update now.”

Viewing 10 replies - 1 through 10 (of 11 total)

You must be logged in to reply to this topic.