Custom Fields
Re-Envisioned
Support General bug with tinymce

  • Creator
    Topic
  • #19112
    Resolved Gunvor
    Participant

    Hi! In my admin panel I don’t use Visual editor in wysiwyg (disabled it in my user settings). I always use Plain Text by default.

    For Metabox I use this code:

                 array(
                        'id' => $prefix . 'docs',
                        'type' => 'group',
                        'clone' => true,
                        'sort_clone' => true,
                        'add_button' => esc_html__( 'add', $mx ),
                        'fields' => array(
                            array(
                                'id' => 'h2',
                                'type' => 'text',
                                'name' => esc_html__( '', $mx ),
                                'placeholder' => esc_html__( 'header', $mx ),
                            ),
                            array(
                                'id' => 'text',
                                'type' => 'wysiwyg',
                                'name' => esc_html__( '', $mx ),
                                'raw' => true,
                                'options' => array( 'textarea_rows' => 10, ),
                            ),
                        ),
                    ),
    

    As you can see, this code allow me to clone field with wysiwyg type. BUT! When when I add a new field by click to “add” button, Metabox is switching to tinymce although it even not exists!

    This is console screenshot: https://i.ibb.co/R9kNHt5/Screen-Shot-2020-04-18-at-13-26-51.png

    Same stuff happens when I just moving field with wysiwyg type (‘sort_clone’ => true).

    Hope you can understand me.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Author
    Replies
  • #19142
    Long Nguyen
    Moderator

    Hi,

    Thank you for contacting us. Hope you are well today.

    I will check it out and let you know later. If you want to use the plain text, please try to use the field textarea instead of WYSIWYG.

    #19159
    Gunvor
    Participant

    Thank you for your answer!

    Yes, I can use textarea, but I need quicktags-toolbar ))

    Any idea how I can add this toolbar to textarea?

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.