Custom Fields
Re-Envisioned
Support Meta Box Builder Can't save location for custom field groups, always reverts to POSTS

  • Creator
    Topic
  • #32125
    DEVIGNR
    Participant

    Using Meta Box Builder + Meta Box Group + MB Custom Post Type (I have MB AIO), I edited a custom field group, and after I saved it the "location" reverted to "POSTS" -- when before it had been set to appear for other custom post types. I tried to change the locations again, but every time I hit save and go back to look at the locations, it is always reverting to POST.

    I need to get this fixed ASAP, because I can not make the adjustments I need when I can't see these options in the correct post types I am editing. I'm sure there have been several updates to metabox AIO since the last time I edited these, but I can't point to a clear time when this may have stopped working.

    Note that I used to be able to do this with no problem, so it is a new issue.

    I tried deactivating all plugins and using default WP theme but no success.

    My WP (5.8.2) and plugins are all up to date, but here is the list just in case:

    Advanced Editor Tools Version 5.6.0
    Akismet Anti-Spam Version 4.2.1
    Classic Editor Version 1.6.2
    Contact Form 7 Version 5.5.2
    Duplicate Page Version 4.4.5
    ManageWP - Worker Version 4.9.10
    Meta Box Version 5.4.8
    Meta Box AIO Version 1.15.2
    No Category Base (WPML) Version 1.3
    UpdraftPlus - Backup/Restore Version 1.16.63
    W3 Total Cache Version 2.2.0
    Wordfence Security Version 7.5.7
    WordPress Importer Version 0.7
    WP Database Backup Version 5.8.1

    Here are screenshots, the first one shows what is keeps defaulting to after I save, and the second one shows the custom post types I am trying to change to.

    Always defaualts to this

    But I want to save to this

Viewing 3 replies - 1 through 3 (of 3 total)
  • Author
    Replies
  • #32142
    Long Nguyen
    Moderator

    Hi,

    I have had an experience with a similar issue before, the way to resolve it is to create a new field group and assign the post type. Can you please confirm that works?

    #32150
    DEVIGNR
    Participant

    Yes I confirmed it works, but are you serious? This is not a bug that needs to be fixed? The particular group I need to update has like 75 different options, it would take me hours to rebuild it.

    #32161
    Long Nguyen
    Moderator

    Hi,

    Can you please export that field group and share it here? I will import it to my demo site and check the issue.
    https://docs.metabox.io/extensions/meta-box-builder/#export--import

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.