Custom Fields
Re-Envisioned
Support MB Term Meta Check Composer.json information

  • Creator
    Topic
  • #20735
    Resolved Content Pilot
    Participant

    Hi.

    Today, July 10, 2020, tried to install the MB Term Meta plugin via Composer and it failed to say it can’t find the package or it can’t resolve the version number. This has worked in the past so I wonder if something has changed recently or if the composer.json or repo URL needs to be updated or change. I am not really sure about how to fix it. I just know that it didn’t work for me today when running a composer install for my plugin that requires the mb-term-meta package.

    Thank you!

Viewing 2 replies - 1 through 2 (of 2 total)
  • Author
    Replies
  • #20750
    Long Nguyen
    Moderator

    Hi,

    I’ve tested to install the extension MB Term Meta via Composer and it works as well. Maybe something goes wrong at that time, you can also re-install this extension with the sample composer code and follow this documentation https://docs.metabox.io/extensions/composer/#versions–updates.

    {
      "repositories":[
        {
          "type": "composer",
          "url": "https://packages.metabox.io/license-key"
        }
      ],
      "require": {
        "meta-box/mb-term-meta": "dev-master"
      },
      "extra": {
        "installer-paths": {
          "vendor/meta-box/{$name}/": ["type:wordpress-plugin"]
        }
      },
      "autoload": {
        "files": [
          "vendor/meta-box/mb-term-meta/mb-term-meta.php"
        ]
      }
    }

    Let me know how it goes.

    #20758
    Content Pilot
    Participant

    This setup works on the plugin I have built. The failure was coming from another plugin that loads that plugin. Chaining them.

    I had to add "minimum-stability": "dev" to my new composer.json and it works now.

    Please close.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.