Custom Fields
Re-Envisioned
Support General Clone As Multiple Feature Doesn't Work With Taxonomy Advanced Field

This topic contains 5 replies, has 2 voices, and was last updated by  marketing.safesoftware 1 month ago.

  • Creator
    Topic
  • #11584
    Resolved
    marketing.safesoftware
    Participant

    I’m trying to make a field of type taxonomy advanced with similar settings to the below:

    
    'id' => 'custom_taxonomy',
    'name' => 'Custom Taxonomy',
    'type' => 'taxonomy_advanced',
    'taxonomy' => 'custom_taxonomy',
    'clone' => true,
    'clone_as_multiple' => true,
    

    When using clone as multiple, the data is saved to the database as a serialized array when it should be saved to multiple rows instead. Furthermore, the edit page only displays the first of the three taxonomy terms that were selected:

    
    a:3:{i:0;s:3:"670";i:1;s:3:"667";i:2;s:3:"689";}
    

    When clone as multiple is disabled, the edit page displays all three of the selected categories – cloning works as expected.

    Related to this, if I manually create three rows for this taxonomy advanced field when clone as multiple is enabled, then only the first row shows up on the edit page.

    To summarize:
    – The “clone as multiple” feature doesn’t save taxonomy advanced field data in multiple rows.
    – The “clone as multiple” feature only displays one row of data belonging to taxonomy advanced fields.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Author
    Replies
  • #11587

    Anh Tran
    Keymaster

    Hi, thanks for your bug report. Let me check and fix it.

    #11761

    Hi Anh, any updates on this?

    #11776

    Anh Tran
    Keymaster

    Hi, I haven’t done fixing it yet :(. Please wait for a few days.

    #11885

    Anh Tran
    Keymaster

    Hi again, we’ve fixed the bug on Github. Can you please try it?

    #11899

    Hi Anh, I tested the fix and can confirm that it’s working now. Thanks, it’s much appreciated!

Viewing 5 replies - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.