Custom Fields
Re-Envisioned
Support General Composer issues

  • Creator
    Topic
  • #30858

    I am suddenly unable to install MetaBox via composer. My composer file was working last week, but now when I run composer install, I get the following error:

    [Composer\Downloader\TransportException]
    The "https://packages.metabox.io/MY_METABOX_API_KEY/packages.json" file could not be downloaded (HTTP/2 404 )
    <code></code>

    That path, when pasted into a browser, does indeed produce a 404.

    I am including MetaBox like this:

    {
    "type": "composer",
    "url": "https://packages.metabox.io/MY_METABOX_API_KEY"
    }
    <code></code>

    I am also requiring "ffraenz/private-composer-installer": "^5.0"

    I have tried removing my composer.lock file, as well as running composer clear-cache. The error persists (both before and after removing the lock file and clearing caches).

    My composer file has not changed since I was last able to install (last week). Has something on your end changed?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Author
    Replies
  • #30865
    Long Nguyen
    Moderator

    Hi,

    Thank you for your reporting.

    I will inform the development team to check this issue and get back to you later.

    #30866
    Acato
    Participant

    Hi Long Nguyen/MetaBox.io,

    We've got the same issue as Georgetown University Web Services.

    Looking forward to the answer.

    Regards,

    Acato

    #30887
    Long Nguyen
    Moderator

    Hi friends,

    This issue has been fixed, please use this command to clear cache and run composer again.

    rm -rf vendor && composer clear-cache && composer install
    

    Let me know if it works.

    #30903

    Looks like it is working again. Thank you so much!

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.