Custom Fields
Re-Envisioned
Support MB Views Custom fields not showing in ‘Insert Field’ list

  • Creator
    Topic
  • #26543
    Resolved Henri
    Participant

    Hi Metabox,

    I’ve created a custom post with custom fields. When I choose this custom post for a MB view, the custom fields aren’t shown though. I’ve created a screen recording showing the issue: https://share.getcloudapp.com/geu46EWO

    Is this a bug or did I forget some setting that will show the custom fields when enabled?

    Kind regards, Henri

Viewing 9 replies - 1 through 9 (of 9 total)
  • Author
    Replies
  • #26550
    Long Nguyen
    Moderator

    Hi Henri,

    I also see you’ve created this topic https://metabox.io/support/topic/the-supporting-options-of-a-custom-post-type-doesnt-work/.

    Please try to deactivate all plugins except Meta Box, MB extensions and switch to the default theme of WordPress (Twenty TwentyOne) then re-check this issue.

    If it does not help, please share your site credentials via this form https://metabox.io/contact/, I will help you to check it.

    #26552
    Henri
    Participant

    Hi Long,

    I’ve installed the latest WordPress theme and the latest Metabox plugins. I also disabled the other plugin. So it should be a clean installation on WP5.7. I tried it again, but the custom fields are still not showing. However, it also has some strange behavior of showing the terms and then removing them again because there is a tab for that as well. I have recorded the issue again: https://share.getcloudapp.com/ApuR7WBk

    I’ll supply the credentials via the form.

    Kind regards, Henri

    #26560
    Long Nguyen
    Moderator

    Hi Henri,

    The extension MB Views needs the REST API enabled on your site. When checking the site information in Tools > Site Health, I see some issues with your site REST API, screenshot https://share.getcloudapp.com/L1uNLmmw.

    Please try to contact your hosting provider to ask for help to enable Rest API. Then you can re-check the View.

    #26563
    Henri
    Participant

    Hi Long,

    I didn’t see that before. I tried to see what’s wrong, but I couldn’t, so I decided to create a fresh staging site. The rest API error is gone now. I’ve installed everything fresh again. But the custom fields still don’t show in the Insert Field option. See my new recording: https://share.getcloudapp.com/yAu6pd0R

    I do get it to work to just type in the custom field name, like this {{ post.business }}. But I would rather have it shown to just pick the values.

    I’ve recreated the credentials, so you can login to the new staging site with the same credentials.

    Kind regards, Henri

    #26566
    Long Nguyen
    Moderator

    Hi,

    Sorry, forget to mention. The Rest API error shows after switching permalink settings to “Post name”.

    #26612
    Henri
    Participant

    Hi Long,

    did you find anything why the custom post fields are not showing even on the fresh wordpress staging installation?

    Kind regards, Henri

    #26617
    Henri
    Participant

    Hi Long,

    I think I found the issue. I’m using WPVivid plugin to create a staging site. The staging website has the same setup as the main website, so the same plugins. If I install a fresh WordPresss instance and only add the WPVivid plugin, you will only see that in the staging website. So there shouldn’t be anything different form a clean WordPress install.

    However, when I install MB views on the staging website, it doesn’t show the custom fields (after I set those up ofcourse). But when I do the same on the main website, it does show the custom fields.

    So it has something to do with the staging website I’ve created via WPVivid, but what I don’t know. I’m using the same database as the main website, as this is recommended. See: https://wpvivid.com/wpvivid-backup-pro-create-staging-site

    Do you know what it could be?

    And do you know what I could otherwise do? I’m creating a staging site so I can develop the website. If I can’t use it with Metabox, I need to find another solution to safely develop a website while leaving the production website untouched.

    Kind regards, Henri

    #26627
    Long Nguyen
    Moderator

    Hi,

    Please try to contact the plugin WPVivid to ask to enable REST API on the staging site. On your live site, it still works as well as you see.

    You can refer to this topic from the WP forum https://wordpress.org/support/topic/staging-site-api-call-not-working/.

    #26628
    Henri
    Participant

    Hi Long,

    Thanks, I just send them the message. I’ll let you know if that will solve it.

    Kind regards, henri

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.