Custom Fields
Support MB Views Custom post types or taxonomies not showing in MB View

  • Creator
  • #19031
    Resolved SAND

    I'm trying to use Views to display custom taxonomy terms on the homepage.
    But when I click on "Insert field" only post fields are showing, custom post types or taxonomies are not shown.
    Do you know why the fields of custom post types or taxonomies are not showing?

    Thanks in advance,

Viewing 6 replies - 11 through 16 (of 16 total)
  • Author
  • #19121

    Ok, thanks Long for all your good and quick answers!
    Highly appreciated.


    With some trial and error I managed to add the links to the term archive.
    I've used the following code:

    {% set terms = mb.get_terms( 'symptoom' ) %}
        {% for term in terms %}
         {% set termlink = mb.get_term_link(term)%}
            <a href="{{termlink}}">{{}}</a> ,
        {% endfor %}

    It works, but I'm not sure if this is the best way to write the code.
    So, please show me if I should write it differently.

    Long Nguyen


    Yeah, the code shows the terms of symptoom and link to the archive page as well. Keep up the good work.


    Thanks, with your help I'm learning to use and I'm finding out it can really do a lot! Next thing I'm going to use is MB Relationships and MB Admin Columns.


    Hello. I am having a similar problem as the original poster described. When I add a View and try to insert a field, I can see the following tabs: Post, Term, User, Site, Query, View. But my custom post type, custom fields, and custom taxonomy do not show up anywhere.

    In the MB View tutorial video, the screen showed the custom post type fields at the bottom. So I am not sure why I am not getting them. My screen does not match what was shown on the tutorial.

    I tried clearing the cache, but the problem persists.

    I am using MB View as part of the Meta Box AIO package.


    Update: I started again from scratch on a different host and everything works fine now. I am still not sure what caused the earlier problem (was it a plugin incompatibility or a server setting?) but all is well now.

Viewing 6 replies - 11 through 16 (of 16 total)
  • You must be logged in to reply to this topic.