Custom Fields
Re-Envisioned
Support General Error when creating Taxonomy

This topic contains 3 replies, has 2 voices, and was last updated by  Truong Giang 1 year, 10 months ago.

  • Creator
    Topic
  • #6693

    anthonycamilleri
    Participant

    I have created a taxonomy using MB Custom Post Type, however, when I paste the code into functions.php, it gives the following error in place of the taxonomy meta-box:

    Warning: call_user_func() expects parameter 1 to be a valid callback, no array or string given in /home/…/wp-admin/includes/template.php on line 1050

    The code generated by MB Custom Post Type is: http://txt.do/d61bi

Viewing 3 replies - 1 through 3 (of 3 total)
  • Author
    Replies
  • #6699

    Truong Giang
    Participant

    Hi there,

    Do you use latest version of MB Custom Post Type? There is something wrong here. It’s should be add_action( 'init', 'your_prefix_register_taxonomy', 0 ); instead of add_action( 'init', 'your_prefix_register_taxonomy');

    I used the code you give but I didn’t see any errors.

    #6702

    anthonycamilleri
    Participant

    Hi, I’ve tried this with the corrected code and still the error remains the same. Just to be clear, the taxonomy works fine as long as I am using it ‘dynamically’ through MB Custom Post Type. As soon as I copy the code to php and disable the plugin, the error starts appearing.

    #6708

    Truong Giang
    Participant

    Which version of MB Custom Post Type are you using? I tried your scenario but it works. Can you share your credential for us to check it? If you can, please send the WordPress admin credential to support@metabox.io

    Thank you very much.

    UPDATE: Sorry. I got the problem. Please wait for me to fix it.

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.