Custom Fields
Re-Envisioned
Support MB Settings Page Fatal error: Uncaught Error: Class 'MBBParser\Arr' not found

  • Creator
    Topic
  • #28223
    Resolved Mary Leir
    Participant

    When I am on the Edit Settings Page screen and click to update, I get a fatal error:

    Fatal error: Uncaught Error: Class 'MBBParser\Arr' not found in
    wp-content/plugins/meta-box-aio/vendor/meta-box/meta-box-builder/modules/settings-page/src/Parser.php:28
    Stack trace:
    #0 /wp-content/plugins/meta-box-aio/vendor/meta-box/meta-box-builder/modules/settings-page/src/Parser.php(9): MBB\SettingsPage\Parser->parse_menu_icon()
    #1 /wp-content/plugins/meta-box-aio/vendor/meta-box/meta-box-builder/modules/settings-page/src/Edit.php(41): MBB\SettingsPage\Parser->parse()
    #2 /wp-content/plugins/meta-box-aio/vendor/meta-box/meta-box-builder/src/BaseEditPage.php(49): MBB\SettingsPage\Edit->save(3046, Object(WP_Post))
    #3 /wp-includes/class-wp-hook.php(294): MBB\BaseEditPage->save_wrapper(3046, Object(WP_Post))
    #4 /wp-includes/class-wp-hook.php(316): WP_ in /wp-content/plugins/meta-box-aio/vendor/meta-box/meta-box-builder/modules/settings-page/src/Parser.php on line 28

    The changes are saved even with this error. Interestingly, on my local install, I see the icon type and icons, but on my published site I see the icon grid in a flash but it's not visible when the page loads. I get the same error on both environments.

    Additionally, the link to the settings page does not show up in the left menu.

    Finally, when I click the Generate in the "Get PHP code" panel, the message "Generating code, please wait..." appears but no code appears.

    I've uninstalled and reinstalled. I've turned off all plugins and tried again. Any other suggestions for troubleshooting this?

    Thank you!!

Viewing 3 replies - 1 through 3 (of 3 total)
  • Author
    Replies
  • #28225
    BognerIT
    Participant

    Hi,

    I was about to open a new post about this error, because I am currently facing the same problem. Here are details about my stack.

    Stack

    • WordPress 5.7.1
    • Nginx
    • PHP 7.4
    • MariaDB

    Installed plugins (All up to date)

    • Dashboard Customizer
    • Editor Enhancer
    • HappyFiles Pro
    • Hydrogen Pack
    • Meta Box
    • Meta Box AIO
    • Oxy Toolbox
    • OxyExtras
    • Oxygen
    • OxyNinja
    #28229
    Long Nguyen
    Moderator

    Hi,

    Please update the new version of Meta Box AIO 1.13.11 or Meta Box Builder 4.1.5 to fix this issue.

    #28235
    Mary Leir
    Participant

    Thank you! The update solved the issue.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.