Custom Fields
Re-Envisioned
Support Meta Box AIO Field image_upload stop to works after last update

This topic contains 4 replies, has 2 voices, and was last updated by  Jefferson 3 months, 1 week ago.

  • Creator
    Topic
  • #14897
    Resolved
    Jefferson
    Participant

    After last update of MetaBox and MetaBox AIO, the javascscript upload metabox stop to work correctly.

    CONSOLE ERROR:
    Uncaught TypeError: this.$input.data(…).map is not a function
    FILE: media.js?ver=4.18.2:129

    Looking for the info of gallery in my database I found records (new) where the object have the first item are empty. e.g:
    a:6:{i:0;s:0:””;i:1;s:5:”19966″;i:2;s:5:”19967″;i:3;s:5:”19968″;i:4;s:5:”19969″;i:5;s:5:”19970″;}

    My WordPress Version: 5.2.1

    How can I fix it?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Author
    Replies
  • #14907

    Anh Tran
    Keymaster

    Hi @Jefferson,

    Can you post the code of the gallery field and do you know why the first item is empty?

    #14914

    Jefferson
    Participant

    Hi @Anh

    this is the code of field:

    array(
       'id'   => 'images',
       'type' => 'image_upload',
       'name' => esc_html__( 'Imagens', 'webpesados' ),
       'force_delete' => true,
       'image_size' => 'thumbnail',
       'columns' => 12,
       'tooltip' => array(
          'icon' => 'help',
          'content'   => esc_html__('Arraste as imagens para alterar sua ordem de exibição.', 'webpesados'),
          'position' => 'right',
       ),
    ),

    Why the first item is empty? I not know. When I upload images and save the post, the data are saved with first item empty. And in this case, after save the post the galery metabox is not displayed.

    #14934

    Anh Tran
    Keymaster

    Hi @Jefferson, I’ve fixed this bug here. Please try it.

    #14938

    Jefferson
    Participant

    Hi @Anh, works fine now! Thank you!

Viewing 4 replies - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.