Custom Fields
Re-Envisioned
Support General Impossible to edit Custom Fields

  • Creator
    Topic
  • #24612
    Resolved poehnix
    Participant

    Hello everyone,
    I have a blocking issue with Metabox custom fields.

    I have created 4 Field groups, each with several fields inside. Everything was fine at creation time but now, when I try to edit them I got the message

    "Loading settings please wait"

    and then the custom fields created do not show. The only thing that shows is Field group Name.
    So I am unable to modify the custom fields.

    Export function and add new (custom created) content seems to work.

    Php error log does not show any error. Debug is Active.

    I am using latest WordPress, Metabox AIO, Apache and Php 7.4. No other plugin or theme.
    CPT and Custom fields are made using the interface (not exported in php)

    Does anyone have a clue of what I can do to overcome the issue ?
    Thank you
    poehnix

Viewing 5 replies - 1 through 5 (of 5 total)
  • Author
    Replies
  • #24614
    poehnix
    Participant

    Followup:
    I reinstalled everything from scratch, getting php code for moving CPTs and exporting + importing json for Custom Field gruops, so basically using the same codebase in the corrupted and clean installation and that seemed to made the trick but of course this is not the right solution.

    Now website is empty and under construction. Once it goes live reinstalling and configuring everything from scratch plus importing all the content won't be a choice.

    What can I do to make fields / settings appear again, once they are gone ? Might be related to permalink structure change ? This is the only thing I changed (and reverted back once I foound the issue)

    #24615
    Long Nguyen
    Moderator

    Hi,

    It might relate to the permalink structure, please refer to this topic https://metabox.io/support/topic/problems-creating-custom-fields/.

    #24643
    poehnix
    Participant

    Hello,
    thank you for your quick response.
    Using the custom permalink structure given in the video you linked, the only difference I notice is that the "Loading settings, please wait..." stays visible, while with no permalink the message pops in for a second and than it goes away (without loading the custom fields )
    Looking at js Debugger window in Firefox I get the following :

    Uncaught (in promise) SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data

    For now, to continue developing the site I will use the second installation I have done on my local development machine.
    It would anyway be important to have a solution to the problem, should it happen again once the site goes in production.

    Let me know if you need additional debugging info

    Thanks again
    poehnix

    #24644
    poehnix
    Participant

    After further inspection I found I had a problem with my apache conf.
    Fixing it had two consequences:

    -THE GOOD: now the "Add field" ui interface works again
    - THE BAD: all custom fields (in every Field Group) are lost both for edit and export

    Luckily enough i had exported them to build 2nd installation.

    I guess we can mark the issue as solved.
    Thank you
    poehnix

    #24844
    Steven Kwok
    Participant

    Any other solutions for this bug? I tried to follow the instruction in this post but the issue still exists.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.