Custom Fields
Re-Envisioned
Support Meta Box Builder Last update breaks my wordpress

  • Creator
    Topic
  • #21005
    Resolved DUPLO
    Participant

    Hi,
    I just update my MB Builder and it broke my wordpress. I have to disable the plugin to access to the admin. The error shown is this:

    Warning: require(/usr/home/domain.com/web/wp-content/plugins/meta-box-builder/vendor/composer/../meta-box/mbb-parser/src/functions.php): failed to open stream: No such file or directory in /usr/home/domain.com/web/wp-content/plugins/meta-box-builder/vendor/composer/autoload_real.php on line 66 Warning: require(/usr/home/domain.com/web/wp-content/plugins/meta-box-builder/vendor/composer/../meta-box/mbb-parser/src/functions.php): failed to open stream: No such file or directory in /usr/home/domain.com/web/wp-content/plugins/meta-box-builder/vendor/composer/autoload_real.php on line 66 Fatal error: require(): Failed opening required '/usr/home/domain.com/web/wp-content/plugins/meta-box-builder/vendor/composer/../meta-box/mbb-parser/src/functions.php' (include_path='.:/usr/home/sys/phpfarm/inst/php-7.2.5/pear/php/') in /usr/home/domain.com/web/wp-content/plugins/meta-box-builder/vendor/composer/autoload_real.php on line 66

    Please help me!

Viewing 8 replies - 1 through 8 (of 8 total)
  • Author
    Replies
  • #21007
    DFM
    Participant

    Just the same: I’ve just upgraded to Meta Box Builder 3.3.5 and it’s hosed the wordpress install, s reported by WordPress ( 5.4.2 )

    Version 3.3.5 | By MetaBox.io | Visit plugin site

    This plugin failed to load properly and is paused during recovery mode.

    An error of type E_COMPILE_ERROR was caused in line 66 of the file [redacted]/www/wp-content/plugins/meta-box-builder/vendor/composer/autoload_real.php. Error message: require(): Failed opening required ‘[redacted]/www/wp-content/plugins/meta-box-builder/vendor/composer/../meta-box/mbb-parser/src/functions.php’ (include_path=’.:/usr/share/php’)

    check on the filesystem that file does indeed not exist at

    [redacted]/www/wp-content/plugins/meta-box-builder/vendor/meta-box/mbb-parser/src/functions.php

    ls -l [redacted]/www/wp-content/plugins/meta-box-builder/vendor/meta-box/mbb-parser/
    total 0

    ls -l /srv/sites/chisenhale.org.uk/www/wp-content/plugins/meta-box-builder/vendor/meta-box/
    total 4
    drwx—r-x 2 www-data www-data 4096 Jul 29 12:52 mbb-parser

    I’ve tried to remove the plugin and re-install and the problem persists. Permission are all correct for nginx and php-fpm to load the files if they exist. The file it’s looking for is simply not there.

    Fix needed asap.

    #21008
    mark@olypress.com
    Participant

    We had the same thing happen this morning to several sites.

    PHP Fatal error: require(): Failed opening required ‘/nas/content/live/x/wp-content/plugins/meta-box-builder/vendor/composer/../meta-box/mbb-parser/src/functions.php’ (include_path=’.:/usr/share/pear/php:/usr/share/php’) in /nas/content/live/acmhsprod/wp-content/plugins/meta-box-builder/vendor/composer/autoload_real.php on line 66

    #21012
    Long Nguyen
    Moderator

    Hi guys,

    Hotfix, please download this file and extracted https://drive.google.com/file/d/1s0XaxS9Sm4tZcR9nQZgTd1aKVhW7PVZJ/view?usp=sharing.

    Then replace the folder mbb-parser in this path wp-content/plugins/meta-box-builder/vendor/meta-box/. The new version will be released as soon as possible to cover the issue.

    #21015
    Cristian A.
    Participant

    same problem here 🙁 I have more than 5 sites broken because of that

    #21016
    DFM
    Participant

    Hi @long

    I can confirm that fix works for me. Many thanks.

    #21021
    Long Nguyen
    Moderator

    Hi all,

    Please update the new version v3.3.6 of this extension to fix the issue.

    Thank you and have a good day.

    #21023
    DUPLO
    Participant

    Thanks for your effort Long Nguyen!!!

    #21024
    John Anderson
    Participant

    Hi I just came across this as well. FTP in and remove the plugin meta-box-builder. download the newest version from this site then install it like you would a new plugin.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.