Custom Fields
Re-Envisioned
Support MB Term Meta MB Term Meta Data not saving

This topic contains 13 replies, has 6 voices, and was last updated by  Anh Tran 1 week, 2 days ago.

  • Creator
    Topic
  • #6387
    Resolved
    uththamag
    Participant

    Hi,

    When I added an image to taxonomy and update, the image was not saving. There is a big issue need to fix this soon. otherwise, i have to go for another plugin.

    This is my code.

        $meta_boxes[] = array(
            'title'         => false,
            'taxonomies'    => 'main_services',
            'fields' => array(
    
                // Photo
                array(
                    'name'             => esc_html__( 'Service Thumbnail', 'codice' ),
                    'id'               => "{$prefix}thumb",
                    'type'             => 'image_advanced',
                    'max_file_uploads' => 1,
                    'max_status'       => false,
                ),
    
            )
        );

    Thank you

Viewing 10 replies - 1 through 10 (of 13 total)
  • Author
    Replies
  • #6391

    Truong Giang
    Participant

    I tested with the code you give but it works great. Please make sure that you are using MB Term Meta version 1.2

    #6392

    uththamag
    Participant

    Hi, Truong.

    I’m Using the latest – MB Term Meta 1.2

    Pls help. Need to fix this asap.

    Thank you

    #6393

    Truong Giang
    Participant

    I checked again but can’t find the issue. Can you give me the list of plugins (with version) are you using?

    #6394

    uththamag
    Participant

    I’m using below versions.

    Meta Box 4.12.2
    MB Term Meta 1.2
    Meta Box Conditional Logic 1.4.1
    Meta Box Group 1.2.8
    Meta Box Columns 1.0.2
    Meta Box Include Exclude 1.0.9

    Ninja Forms 3.1.6
    Slider Revolution 5.4.5.1
    SVG Support 2.3.10
    Yoast SEO 5.0.2
    Duplicate Post 3.2
    Black Studio TinyMCE Widget 2.3.2

    #6395

    Jackky
    Participant

    Note, that metaboxes appears only when you EDIT existing term, not when you are on the “main” page of all terms.

    If they still not working, set DEBUG to true in your wp_config.php and see what you get in errors.

    #6402

    Truong Giang
    Participant

    @uththamag Have you seen any js errors in the browser console?

    #6404

    uththamag
    Participant

    Hi,

    I think I found the issue. No Js errors Truong. The issue is:

    MB Term Meta Data not saving existing taxonomy category. But if I adding a new item(taxonomy category), and upload a featured image it will work. Also, I can edit the feature image of this item.

    Thanks

    #6449

    Truong Giang
    Participant

    I tried again and again but it still works with existing term. Can you try it on a fresh WordPress site?

    #6731

    akabaka
    Participant

    I am having the same problem. Here are my fields:

    add_filter( 'rwmb_meta_boxes', 'aka_register_taxonomy_meta_boxes' );
    function aka_register_taxonomy_meta_boxes( $meta_boxes )
    {
    	$meta_boxes[] = array(
    		'title'      => 'Guest Category Fields',
    		'taxonomies' => 'guestcats',
    		'fields' => array(
    			array(
    				'name' => 'Featured image',
    				'id'   => 'guestcatimage',
    				'type' => 'image_advanced',
    				'max_file_uploads' => 1,
    			),
    			array(
    				'name' => 'Include in ‘Guests by Fandom’ pulldown?',
    				'id'   => 'guestbyfandom',
    				'type' => 'checkbox',
    			),
    		),
    	);
    	return $meta_boxes;
    }

    Some of the categories work as expected, but others will not save either the checkbox or the image. What’s stranger is: when it fails to save an image to one of the terms, that image gets saved to one of the other terms that had been working. I have WP debug enabled and don’t see any errors. Any suggestions?

    #6737

    akabaka
    Participant

    So, my Term Meta plugin was the most recent version, but I just noticed there was an update to the main Meta Box plugin that I hadn’t installed yet. After I made that update, this problem seems to have been resolved. I will monitor and update if anything crops up again.

Viewing 10 replies - 1 through 10 (of 13 total)

You must be logged in to reply to this topic.