• Creator
    Topic
  • #26481
    Resolved Steve
    Participant

    Hi,

    I couldn't find a specific forum for the MB User Avatar extension so I'm posting here as they're closely linked.

    I'm using Oxygen and when I try to display the custom user avatar through dynamic data from author or user image, it pulls in the selected default avatar in >Settings>Discussions e.g mystery person or Gravatar logo etc, instead - even though all of these default avatars are replaced with the custom avatar image.

    How would I display the custom avatars?

    Thanks

Viewing 6 replies - 1 through 6 (of 6 total)
  • Author
    Replies
  • #26489
    Long Nguyen
    Moderator

    Hi Steve,

    You can refer to this topic https://metabox.io/support/topic/metabox-user-avatar-not-working-with-elementor-author-widget/.

    To get the code to show the custom avatar when using the component WordPress > Dynamic Data > Author Avatar of Oxygen Builder. Screenshot https://share.getcloudapp.com/eDu8GoW2.

    Apply the code with the plugin Code Snippets https://wordpress.org/plugins/code-snippets/ because I see the site does not run the file functions.php of the theme when editing the page with Oxygen.

    #26497
    Steve
    Participant

    Hi,

    I did see that post and I have tried the code out, placing it into functions.php, however it is still displaying the default avatars. The custom avatar is displayed correctly in the default admin locations but any other custom locations, frontend or otherwise reverts to the default avatar selected in >settings>discussion - which incidentally does display the custom avatar image in place of the default.

    Thanks

    Steve

    #26502
    Long Nguyen
    Moderator

    Hi,

    Did you try to use the plugin Code Snippets?
    https://wordpress.org/plugins/code-snippets/

    I've explained the reason to use this plugin above.

    #26504
    Steve
    Participant

    Hi,

    I use a custom plugin with a functions.php file for Oxygen, then I used the Code Snippets plugin to double check and it still didn't work.

    Thanks

    #26523
    Steve
    Participant

    Hi,

    So I'd like to update that I checked the code on another test site and it did work as expected. Both sites are on the same server, same setup, same plugins, I even deactivated all the plugins on the first site and it still didn't work so I don't know what to say - it works on one but not the other! So I guess it's resolved in that respect, except for this anomaly.

    Thanks for your quick response as always.

    #29832
    concan@gmail.com
    Participant

    Same issue here, also Oxygen.
    I also followed this tutorial https://medium.com/meta-box/create-a-custom-avatar-for-user-with-meta-box-plugin-6b98abfd8bec ,and it works fine for the user profile. But it doesn't work when I actually try to pull it into Oxygen.
    I've tried pretty much everything.
    Not even the simple code block as described in the docs returns the image.

    rwmb_the_value( 'user_photo', array( 'size' => 'thumbnail' ) );
    

    The method described here https://metabox.io/support/topic/metabox-user-avatar-not-working-with-elementor-author-widget/ also just returns the default avatar graphic, not the actual set author image.
    The image displays fine (as uploaded image and as user avatar) in the user profile though, but not when I try to pull it into an Oxygen template.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.