Custom Fields
Re-Envisioned
Support Meta Box Group Not able to save my pages with cloned groups

This topic contains 3 replies, has 2 voices, and was last updated by  jeroensijbom 2 years, 8 months ago.

  • Creator
    Topic
  • #4299

    jeroensijbom
    Participant

    Hi,

    I’m not able to save posts with cloned meta box groups. Only posts with extisting cloned groups with data already in it have this problem, not on newly created post. The error message is a frontend javascript validation error i think (request is blocked before submit). It says “Use the requested format” on top of the screen.

    Kind regards,
    Jeroen

Viewing 3 replies - 1 through 3 (of 3 total)
  • Author
    Replies
  • #4300

    jeroensijbom
    Participant

    Ok, i’ve fixed it. Empty colorpickers were filled with the value # as a default. De error notification is on top of the screen instead of near the field, so when i turned off javascript the error was placed right under the input field of the color picker.

    An update in the plugin has caused this problem. Maybe its good to create a fix for it. Its a fix for people using the plugin over serveral updates i think.

    #4316

    Anh Tran
    Keymaster

    I’ve just tried a cloneable group with a color field and doesn’t see that bug. Also, the code to remove the default ‘#’ is added to Meta Box quite a long time ago. Can you give me more details on that? How did you setup the meta boxes?

    #4333

    jeroensijbom
    Participant

    Tnx! The code looks good. I cant see the bug too, only for old pages that use meta box group for along time. It’s hard to reproduce.

    This is how its included:

    https://ghostbin.com/paste/kez5a

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.