Custom Fields
Re-Envisioned
Support General oEmbed Field Connection prints message on front end when empty

This topic contains 5 replies, has 2 voices, and was last updated by  meta_gecko 7 months, 1 week ago.

  • Creator
    Topic
  • #10565

    meta_gecko
    Participant

    Hi,

    With the oEmbed field, there is a built in check that prints out a message on the front end when it is empty.

    I would like to use a use a condition where the post will show the Video IF it exists, and if it does not then the post will use an image, or a fallback.

    However if I try to do this, then the following message appears on ALL posts when there is no video:

    Embed HTML not available

    This is highly undesirable. Any ideas how to fix it?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Author
    Replies
  • #10567

    meta_gecko
    Participant

    I’m stumped on this one. I removed that annoyance manually for the moment, but obviously it will keep coming back with every update so I need to find how to fix this permanently please.

    I don’t understand why that check is hardcoded into the field with no options to turn it off from the field parameters?

    Also would like to be able to change the wording with a filter in the cases where it might be useful to display a message.

    Also, why is it printing out on the front end of the site? If you are going to do that then at least wrap the message with a CSS class of its own so that it can either be removed with CSS, JS, and or/styled to look more attractive.

    Thanks, looking forward to a resolution.

    #10576

    Anh Tran
    Keymaster

    Hi Guy,

    Thanks for your suggestion. Yes, it was hardcoded in the plugin. I’ll add an option & filter for the message and wrap it in a CSS class. That’s a good idea.

    #10579

    meta_gecko
    Participant

    Thanks Anh, appreciate it.

    #10583

    Anh Tran
    Keymaster

    Done. It’s now available on Github.

    #10590

    meta_gecko
    Participant

    Thanks, I’ve cloned the repo, will test it later this afternoon.

Viewing 5 replies - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.