Custom Fields
Re-Envisioned
Support MB Term Meta PHP Fatal Error after updating from Version 1.2.5 to 1.2.7

This topic contains 3 replies, has 3 voices, and was last updated by  Anh Tran 5 days, 7 hours ago.

  • Creator
    Topic
  • #16739
    Resolved
    Darren Shea
    Participant

    PHP Fatal error: Uncaught Error: Class 'MBTM\Loader' not found in /wp-content/plugins/mb-term-meta/mb-term-meta.php:35

    Any idea why this would occur? We are using Version 5.2.2 of the Meta Box plugin.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Author
    Replies
  • #16741

    Anh Tran
    Keymaster

    Hi Darren, can you please try re-installing the plugin? I’ve just checked and see the Loader class is available within the plugin.

    #16851

    Daniel
    Participant

    I encountered this issue as well.

    I was tempted to downgrade the plugin, but I couldn’t find a way to access older versions of the plugins so I debugged the code a little bit and found out that the following line (mb-term-meta.php:34) has to be changed so that the plugin works as expected

    From:
    require 'vendor/autoload.php';

    To:
    require __DIR__ . '/vendor/autoload.php';

    Could you push this change and release an update?

    By the way, is there a way to download a specific version of a plugin by using a parameter in the download url?

    Daniel

    #16866

    Anh Tran
    Keymaster

    Hi Daniel, thanks for your help. I’ve made the change and released a new version 1.2.8.

    At the moment, the download version is always the latest one.

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.