Custom Fields
Re-Envisioned
Support MB Frontend Submission Problem with MB Frontend Submission and wp multisite

  • Creator
    Topic
  • #22270
    wagdywageh
    Participant

    Hi,
    I added MB Frontend Submission in wp multisite for my client and try to upload an image to the post Thumbnail and he gets an error (An error occurred in the upload. Please try again later.)
    here is an image link for the error .

    https://drive.google.com/file/d/1kFNWBuC2FHAF-45J1qBHb6LXvSqLXgXa/view?usp=sharing

    please this problem so urgent so please give me your feedback as soon as possible and thanks a lot for your help.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Author
    Replies
  • #22287
    Long Nguyen
    Moderator

    Hi,

    Some fields use the WordPress Media Library (popup) to upload images and need a high level of the user to access the media library. You can use the field image to allow the user to upload images without using the media library.

    For more information, please follow the documentation https://docs.metabox.io/extensions/mb-frontend-submission/#upload-files–images-with-the-media-popup.

    #22297
    wagdywageh
    Participant

    Hi Long,

    Thanks for your help. I’ve followed the exact steps described in the link you have shared earlier, yet I am still facing the same error (shown below) whenever I try to upload any file…any thoughts what I might be missing doing wrong here?

    =========
    project-placeholder.png

    An error occurred in the upload. Please try again later.

    Using the Media library popup is required by my client so it is important for me to know how to upload without errors to through the Media library popup

    Thanks for your efforts and support

    #22298
    Long Nguyen
    Moderator

    Hi,

    Have you added the code to add the capability to a user role? If yes, please share the code. Also, please follow this guide to know how to create the staging site https://www.wpbeginner.com/wp-tutorials/how-to-create-staging-environment-for-a-wordpress-site/.

    Then share the credentials (Admin site and FTP account) via this form https://metabox.io/contact/. I will check it out.

    #22320
    wagdywageh
    Participant

    Hi,
    I did as you say and sent you the data 2 days ago , did you find any update for my problem ?
    please let me know as soon as possible

    #22322
    Long Nguyen
    Moderator

    Hi,

    With the administrator user, I’m able to upload the image via Frontend Submission without any problem. See my screen record https://www.loom.com/share/57d791f3ad2c4391b264777dc3eca8a6.

    Please try to clear the cache, use the incognito mode of the browser, and upload another image again.

    #22327
    wagdywageh
    Participant

    Hi,
    I’ve followed your instructions and clear all the cache and use the incognito mode of the browser, and still have the same problem please check the following url for the video test.

    link:
    https://drive.google.com/file/d/1DJ2XsEVFXVNq2GekkMqtjWlIupVaikm5/view?usp=sharing

    Sorry for chasing but as the website is already live my client is chasing me to git this issue fixed.
    Thanks for your efforts and support

    #22328
    Long Nguyen
    Moderator

    Hi,

    Please try to upload different images to check this issue again. Also, share the image file project-placeholder.png, I will try to upload it on my end. Maybe there is a problem with this file or it was broken.

    #22336
    wagdywageh
    Participant

    Hi ,
    I found out new thing happen yesterday while i was testing the site and try to fix it when i open the wp-admin page for the site and open the dashboard the media uploaded successfully here the video link for it :

    video link:
    https://drive.google.com/file/d/1LhROQfX_ytJOlgkDnPUo1TO6EsvBEgXI/view?usp=sharing

    please check the following link for the image project-placeholder.png ,

    image link :
    https://drive.google.com/file/d/17AunEyxC-eo7zZhWbC8_GnNWTOhBfICP/view?usp=sharing

    thanks a lot for you support

    #22337
    wagdywageh
    Participant

    Hello,
    Sorry I was writing fast, what I meant to say that if I opened WP-Admin dashboard, and try to upload any image through the Media Library, it uploads successfully. But when I try to upload an image using the Media Library though my custom made portal dashboard where I use MB Frontend Submission I get an error:
    An error occurred please try again later
    Taking in consideration that the user accessing the custom made portal dashboard has Admin access on the website (not a Super Admin for the WP Multi Site network).
    Please check the earlier attached video which demonstrate the problem in details.
    Kindly advice how I can resolve this issue to allow the portal users to upload images using Media Library through my custom made portal dashboard.
    Thanks

    #22349
    Long Nguyen
    Moderator

    Hi,

    We have released a new version 1.7.4 of the MB User Profile extension to cover this issue. Please update it and let me know how it goes.

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.