Custom Fields
Re-Envisioned
Support Meta Box AIO Site Health Error with MetaBox enabled

This topic contains 6 replies, has 2 voices, and was last updated by  Charlin 1 month, 2 weeks ago.

  • Creator
    Topic
  • #15935
    Resolved
    Charlin
    Participant

    Hello,

    Since 1 day (maybe 2), on the site-health page (/wp-admin/site-health.php), all of my websites with MetaBox enabled didn’t give me 100%.

    If I test of one on my website to disable all extensions, I can have these 100%, if I turn on all extensions (except Meta Box and Meta Box AIO), still 100%. When I turn on Meta Box and Meta Box AIO. I have these errors…

    Same problem if I turn on only Meta Box extensions and disable others.

    I tried too with a default wordpress theme (example : Twenty nineteen) and I have same issues.

    I checked if I had php errors but nothing when wp_debug was ‘true’ in wp-config.php

    Site Health Screenshot

    Wordpress version : 5.2.2
    All extensions up do date
    Meta Box : 5.1.2
    Meta Box AIO : 1.9.5

Viewing 6 replies - 1 through 6 (of 6 total)
  • Author
    Replies
  • #15936

    Charlin
    Participant

    Sometimes I have these errors on admin

    <b>Notice</b>:  Trying to get property 'plugin' of non-object in <b>/meta-box-aio/vendor/meta-box/meta-box-updater/class-mb-updater.php</b> on line <b>126</b><br />
    <b>Notice</b>:  Trying to get property 'plugin' of non-object in <b>/meta-box-aio/vendor/meta-box/meta-box-updater/class-mb-updater.php</b> on line <b>126</b><br />
    #15938

    Anh Tran
    Keymaster

    Hi Charlin, thanks for your feedback. I’ll check it.

    Regarding the errors in your 2nd reply: it was in older versions of AIO. The latest version of AIO doesn’t have Meta Box Updater anymore and thus, can produce this error.

    #15939

    Charlin
    Participant

    Why I have this error if I have an up to date version of Meta Box AIO ?

    MetaBox Versions

    #15943

    Charlin
    Participant

    I found something.

    If I comment the line 21 on /plugins/meta-box-aio/meta-box-aio.php (session_start()) I have health 100% again.

    I don’t know why

    Edit: I found this topic on wordpress.org

    https://wordpress.org/support/topic/plugin-is-causing-site-health-check-errors/

    If I do

    session_start([
        'read_and_close' => true,
    ]);

    The problem gone. I don’t know if it’s a real fix.

    #15953

    Anh Tran
    Keymaster

    Hi Charlin,

    Thanks a lot for your investigation. Looks like that’s a real fix. I’ll do more research on that and will add it to the plugin.

    Update: the above fix doesn’t work well with MB Frontend Submission and MB User Profile. I have fixed this issue another way and will release new versions for both + AIO soon.

    #15955

    Charlin
    Participant

    Good news.

    Thank you

Viewing 6 replies - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.