Custom Fields
Re-Envisioned
Support Meta Box AIO Sketchfab oembed code problem

  • Creator
    Topic
  • #32276
    Resolved peterteszary@gmail.com
    Participant

    I am creating a site for a client with Metabox and Oxygen. This is a museum site. They have an old site and they want to "Upgrade it". So there are existing content that I would like to recreate on a sophisticated way via Metabox

    This Museum has old finds, which they would like to show on their site with 3D models (Sketchfab).

    It is working if you put the iframe in the content, and in the template, you only call the content itself into a text field. Because if you are trying to put the iframe into an oembed field, it does not show up. If you are trying to put the iframe into a WYSIWYG editor, if you "save/publish/update" the post the oembed Sketchfab content is vanishing.

    Can you help me with this?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Author
    Replies
  • #32278
    Long Nguyen
    Moderator

    Hi,

    The original post: https://mnab.ro/lapidarium-3d/idr-iii1-274/
    The new one: https://mnab.dev.peterteszary.com/lapidarium/idr-iii1-274/

    I do not see any issue with the Sketchfab content. Can you please share some screenshots to point out the difference?

    #32285

    I have tried with oembed field as well, but it does not work at all. So I decided to give a try to the WYSIWYG editor, cause it might be useful, for all kinds of content. Especially that the original content was inside of a WYSIWYG editor as ell. But it just not working. I cannot even "save" the content in it.:

    https://jmp.sh/s5gMCYN

    Thanks,
    Peter

    #32304
    Long Nguyen
    Moderator

    Hi Peter,

    The HTML tag <iframe> is not an allowed tag when you add to the WYSIWYG field content. You can bypass the sanitization to add any HTML tags to this field content.

    Refer to this documentation https://docs.metabox.io/sanitization/

    #32305

    Hi Long,

    Thank you for the information. And If I am not a programmer, how shall I absolve this? Is there any more user-friendly way?

    Thanks.

    #32323
    Long Nguyen
    Moderator

    Hi,

    If you use the Builder to create the field, you can click on the tab Advanced > Custom settings > add the key sanitize_callback and value none then save changes.
    Screenshot https://imgur.com/hyIy5Qp

    #32474

    The solution:

    I have achieved a solution with this plugin: https://hu.wordpress.org/plugins/embedpress/
    After I have installed it, I just had to add the Sketchfab link (URL! not the embedded code) to the oembed field and it worked.

    Hope it helps,
    Peter

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.