Custom Fields
Re-Envisioned
Support Meta Box Group std value for radio not considered on clone

  • Creator
    Topic
  • #18933
    Resolved TimKaufmann
    Participant

    Please consider the following field:

    
    array (
        'id' => $prefix . 'radio_w1rh3xgybz',
        'name' => esc_html__( 'Business address source', 'text-domain' ),
        'type' => 'radio',
        'std' => 'organisation_this',
        'options' => array(
            'organisation_this' => esc_html__( 'This organisation', 'text-domain' ),
            'organisation_other' => esc_html__( 'Other organisation', 'text-domain' ),
            'home' => esc_html__( 'Home address', 'text-domain' ),
        ),
        'inline' => 1,
        'required' => 1,
        'visible' => array(
            'when' => array(
                array (
                    0 => 'contact_post_4jdje2047jy',
                    1 => '!=',
                    2 => '',
                ),
            ),
            'relation' => 'and',
        ),
    ),
    

    That field is located within a group that can be cloned. std is only taken into account for the first dataset, not for clones. I’m on WordPress 5.3.3 with current Meta Box downloaded today.

    Behaviour can be seen here: https://www.dropbox.com/s/90azf5usgoct216/metabox-radio.mp4?dl=0

Viewing 4 replies - 1 through 4 (of 4 total)
  • Author
    Replies
  • #18934
    TimKaufmann
    Participant

    Selects have the same problem.

    #18938
    Long Nguyen
    Moderator

    Hi,

    I’ve tested the default value with the cloneable items and realize it is a bug. I also open an issue for the developer team to fix this bug in the next update as soon as possible.

    Thanks for your patience.

    #20792
    Caballero
    Participant

    Hi,

    Is this bug fixed yet?

    #20794
    Long Nguyen
    Moderator

    Hi,

    Please update the plugin Meta Box to the newest version 5.3.2 and other extensions to fix this issue and get new features/options.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.