Custom Fields
Re-Envisioned
Support MB Custom Post Type The supporting options of a custom post type doesn’t work

  • Creator
    Topic
  • #26542
    Resolved Henri
    Participant

    Hi Metabox,

    I’ve just created a new custom post type where I don’t want to use the editor field. So I’ve disabled the Editor in the Supports tab. However, then it suddenly shows the Custom Fields in the backend although I didn’t activate that option. So I tried a few different options and all don’t behave as expected. With the editor enabled for example I don’t see the custom fields or the author. As soon as I disable the editor, it does show those fields. I’ve made a short video illustrating the problem: https://share.getcloudapp.com/NQuJ2lG5

    Could you check if this is a bug?

    Kind regards, Henri

Viewing 4 replies - 1 through 4 (of 4 total)
  • Author
    Replies
  • #26547
    Long Nguyen
    Moderator

    Hi Henri,

    I’ve re-checked this issue on my local site but not reproduce it. Screen record https://share.getcloudapp.com/p9u8voy1.

    Please try to update the newest version of MB Custom Post Type or MB AIO then re-check it. You can also hide a meta box in Screen Options.

    #26551
    Henri
    Participant

    Hi Long,

    Thanks for the quick reply. I’ve disabled my current Kadence theme and disabled the plugin of WpVivid staging. The only plugins active are now of Metabox. And I’m running the latest WordPress install 5.7.

    I did the test again, and although now it works better with the Editor option disabled. However, when I enable it, it still not works as expected. It still doesn’t show some fields. See the recording: https://share.getcloudapp.com/geu46D6b

    I’ll check my other MB view issue and will get back to you on that too.

    Kind regards, Henri

    #26559
    Long Nguyen
    Moderator

    Hi Henri,

    If you are using the Block Editor and want to show the Custom Fields box after enabling support Custom fields, please open the Preferences > Panel > Turn on Custom fields. Screenshot https://share.getcloudapp.com/v1uNdXk4.

    #26564
    Henri
    Participant

    Hi Long,

    Thanks for pointing that out. That issue is solved then 😊

    Kind regards, Henri

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.