Custom Fields
Re-Envisioned
Support Meta Box Builder Uncaught Error after Meta Box Update

  • Creator
    Topic
  • #17009
    Martin Müller
    Participant

    Hello,

    today I updated our Metabox Core plugin which causes now an error while trying to add or edit a custom field.
    We run wordpress 4.8.11 and the latest MetaBox Plugin (5.2.3) as well as the latest MB Core Plugin (1.0.5)
    Here is the error we are getting after clicking “add” under “Custom fields”

    Uncaught Error: Call to undefined function MBB\wp_enqueue_code_editor() in /var/www/vhosts/hosting10519.af95f.netcup.net/httpdocs_wiki/wp-content/plugins/mb-core/vendor/meta-box/meta-box-builder/src/Edit.php on line 41
    enqueue()
    wp-includes/class-wp-hook.php:298
    apply_filters()
    wp-includes/class-wp-hook.php:323
    do_action()
    wp-includes/plugin.php:453
    do_action()
    wp-admin/admin-header.php:97
    require_once()
    wp-admin/edit-form-advanced.php:472
    include()
    wp-admin/post.php:179

    Can you please fix that quickly or give us the possibility to downgrade to Version 1.0.3 of MB Core for example.
    Cheers

Viewing 10 replies - 1 through 10 (of 11 total)
  • Author
    Replies
  • #17012
    Martin Müller
    Participant

    Can you please provide a quick solution?

    #17022
    Martin Müller
    Participant

    It definitely seems to be an error with the MB core plugin, in particular, the MB builder part. I downgraded to Metabox 5.1.2 but this didn’t help. Then, instead of using the core plugin, I installed all the latest versions of the plugins manually and get the same error. Where can I get previous versions of the plugins? Please again, provide a quick solution.
    Cheers
    MM

    #17023
    Anh Tran
    Keymaster

    Hi Martin, I’m checking it now. I’ll fix and update the plugin asap. Please wait.

    #17025
    Martin Müller
    Participant

    For now, I found a backup of previous plugin installation zip files, which I downloaded here under my account in June 2019. It’s working again but please be so kind and let us update the plugins.

    Cheers
    MM

    #17026
    Anh Tran
    Keymaster

    Hi Martin, I found the problem. The Meta Box Builder uses the function wp_enqueue_code_editor, which available in WordPress 4.9. That causes the problem on your site, since you’re running 4.8.11 version of WP. Can you update WP to 4.9? It’s the latest stable version before Gutenberg (5.0).

    #17027
    Martin Müller
    Participant

    Hey Anh, No sorry we can not update to 4.9 quickly since of theme compatibility issues.

    #17029
    Anh Tran
    Keymaster

    I see. Let me try to isolate that part to make it available only when needed.

    #17030
    Martin Müller
    Participant

    thank you very much

    #17034
    Martin Müller
    Participant

    Hey,
    we managed to update to WordPress 4.9.12 but now we get another Error:

    Uncaught Error: Call to undefined function use_block_editor_for_post_type() in /var/www/vhosts/hosting10519.af95f.netcup.net/httpdocs_wiki/wp-content/plugins/mb-core/vendor/meta-box/meta-box-builder/src/helpers.php on line 58
    {closure}()
    array_map()
    wp-content/plugins/mb-core/vendor/meta-box/meta-box-builder/src/helpers.php:60
    mbb_get_post_types()
    wp-content/plugins/mb-core/vendor/meta-box/meta-box-builder/src/Edit.php:95
    enqueue()
    wp-includes/class-wp-hook.php:286
    apply_filters()
    wp-includes/class-wp-hook.php:310
    do_action()
    wp-includes/plugin.php:453
    do_action()
    wp-admin/admin-header.php:97
    require_once()
    wp-admin/edit-form-advanced.php:483
    include()
    wp-admin/post.php:180

    Do we need WordPress 5.0?

    #17059
    Anh Tran
    Keymaster

    Hi, I’m still working on this bug. The function use_block_editor_for_post_type is available on WP 5. Please wait a little if you can’t upgrade to WP 5.

Viewing 10 replies - 1 through 10 (of 11 total)
  • You must be logged in to reply to this topic.