black friday sale

Custom Fields
Re-Envisioned
Support Meta Box AIO Uncaught Error: Class ‘MBBParser\Parsers\Metabox’ not found

  • Creator
    Topic
  • #21234
    Resolved isaacborup@gmail.com
    Participant

    Here is the full error details:

    Error Details
    =============
    An error of type E_ERROR was caused in line 180 of the file /srv/htdocs/wp-content/plugins/meta-box-aio/vendor/meta-box/meta-box-builder/src/Edit.php. Error message: Uncaught Error: Class 'MBBParser\Parsers\MetaBox' not found in /srv/htdocs/wp-content/plugins/meta-box-aio/vendor/meta-box/meta-box-builder/src/Edit.php:180
    Stack trace:
    #0 /wordpress/core/5.5/wp-includes/class-wp-hook.php(289): MBB\Edit->update_meta_box(Array, Array)
    #1 /wordpress/core/5.5/wp-includes/plugin.php(206): WP_Hook->apply_filters(Array, Array)
    #2 /wordpress/core/5.5/wp-includes/post.php(3971): apply_filters('wp_insert_post_...', Array, Array, Array)
    #3 /wordpress/core/5.5/wp-includes/post.php(4354): wp_insert_post(Array, false)
    #4 /wordpress/core/5.5/wp-admin/includes/post.php(419): wp_update_post(Array)
    #5 /wordpress/core/5.5/wp-admin/post.php(227): edit_post()
    #6 {main}
      thrown
Viewing 5 replies - 1 through 5 (of 5 total)
  • Author
    Replies
  • #21237

    I get this error anytime I try to update or trash a custom field. So far, I’ve only tried with Blocks, so I cannot confirm whether this is affecting all custom field types or not.

    I did not seem to have any issues creating new custom fields for Blocks, just updating existing and trying to delete.

    Thanks for any insight you can lend.

    #21242
    Long Nguyen
    Moderator

    Hi,

    Please update the new version 1.11.18 of the extension Meta Box AIO to fix this issue.

    Thank you.

    #21262

    Hi Long,

    I currently have version 1.11.18 installed and am still seeing this issue:

    Current versions of Meta Box and Meta Box AIO
    Plugin Version Screenshot

    #21263

    I also notice that the Code tab when editing the custom fields is showing an error:

    Screen-Shot-2020-08-13-at-12-29-33-PM

    #21264

    RESOLVED

    Completely deleting the plugin and reinstalling from the latest release under My Account seemed to work! Thanks!

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.