black friday sale

Custom Fields
Re-Envisioned
Support Meta Box Geolocation Uncaught ReferenceError: google is not defined

  • Creator
    Topic
  • #22480
    Resolved EricHedvat
    Participant

    Upon activating a plugin caleld Ulisting, my Meta box Map field disappears and i get this error in the console : “Uncaught ReferenceError: google is not defined” in /meta-box/js/map.js. line 271.
    Thanks

Viewing 5 replies - 1 through 5 (of 5 total)
  • Author
    Replies
  • #22486
    Long Nguyen
    Moderator

    Hi,

    There is a conflict between the plugin Meta Box and uListing, both plugins use the Google Map Library and it happens the issue. If you want to use the Meta Box Map and remove the uListing Map, please add this code to the file functions.php in the theme folder or use the Code Snippets plugin.

    add_action( 'admin_enqueue_scripts', function() {
        wp_dequeue_script( 'stm-listing-vue-google-maps' );
    } );
    #22487
    EricHedvat
    Participant

    This doesn’t seem to work I still cant see the map and the address field is not working.

    #22491
    Long Nguyen
    Moderator

    Hi,

    Please clear the browser cache and recheck it.

    #22523
    EricHedvat
    Participant

    Still doesn’t work, I think maybe something needs to be changed in the maps.js file?

    #22525
    Long Nguyen
    Moderator

    Hi,

    Please confirm that it’s the plugin uListing https://wordpress.org/plugins/ulisting/. And it has loaded the Google Map JS in the file wp-content/plugins/ulisting/includes/admin/enqueue.php on line 41.

    wp_enqueue_script('stm-listing-vue-google-maps', ULISTING_URL . '/assets/js/vue/vue-google-maps.js', array('vue'), $v);
    

    You might need to choose another Map Type in Listing Types > Settings > Map Settings. See https://share.getcloudapp.com/7Ku8Q0Ex.

    To unload the Google Map JS of the uListing plugin completely, please contact the plugin support https://wordpress.org/support/plugin/ulisting/.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.