• Creator
    Topic
  • #24854
    Resolved Aart Jan van der Linden
    Participant

    Hi,

    I'm getting this warning:
    Deprecated: Required parameter $template_loader follows optional parameter $post_type in [...]/wp-content/plugins/meta-box-aio/vendor/meta-box/mb-frontend-submission/src/Post.php on line 21

    This line has the issue, with the last parameter being required:

     public function __construct( $post_type = 'post', $post_id = 0, $config = array(), $template_loader ) {
            $this->post_id         = (int) $post_id;
            ....

    Thanx!

    Aart Jan

Viewing 2 replies - 1 through 2 (of 2 total)
  • Author
    Replies
  • #24869
    Long Nguyen
    Moderator

    Hi Aart Jan,

    Thank you for your reporting.

    Are you using PHP 8 version? I suppose that this error notice displays when you update PHP version 7.4 to 8. Some PHP functions need to update to compatible with the new version.

    For stability, please use version 7.4 in a while.

    #24883

    Hi Long,

    yes, that's true. It's happening on my PHP8 testserver, my apologies for not mentioning that.
    Thanx for your reply!

    Best,

    Aart Jan

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.