Custom Fields
Re-Envisioned
Support MB Frontend Submission Ajax Form Submission Isn’t Working

  • Creator
    Topic
  • #19040
    Resolved jason@zrimarketing.com
    Participant

    I have a huge form with multiple cloneable fields. The form work fine when I’m not using ajax, but when I enable ajax the form does not submit correctly. When submitted the confirmation text only says “undefined”, and the data is not recorded in WordPress.

    Here is a link to the form I’m having issues with:
    https://satterleeplumbing.com/test-ajax/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Author
    Replies
  • #19044
    Long Nguyen
    Moderator

    Hi,

    Hope you are well today.

    I’ve opened an issue for the developer team to fix this problem in the next update as soon as possible. At this time, please use the form submit without the Ajax option for a better experience.

    Thanks for your patience.

    #19047
    Anh Tran
    Keymaster

    Hi Jason, can you please share the code of the meta box to test? I don’t see the problem on my localhost.

    #19057

    I posted the code on pastebin. Here is the link:
    https://pastebin.com/usSjgyRg

    #19268

    Is there an update on this issue?

    #19327
    Long Nguyen
    Moderator

    Hi Jason,

    Please update the new version of MB AIO to v1.11.6 or MB Frontend Submission to v2.2.1 then check the problem again. Also, if you want a field that is required, please use the Validation module https://docs.metabox.io/validation/ to work with Ajax setting.

    Let me know how it goes.

    #19431

    Now I’m seeing that this form is not working with or without AJAX. I do not have any required fields. I’m running the newest version. The form works if I’m logged in to WordPress. The form does not work when I use a private window. Here is my code: https://pastebin.com/WsS2cAg3

    #19433

    I’m sorry. It turns out that this problem is due to caching. My host, WP Engine, support helped me find the issue. Anyone who is using WP Engine, must have caching turned off for these pages to work.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.