black friday sale

Custom Fields
Re-Envisioned
Support MB Custom Post Type CPTs and Taxonomy register issues

  • Creator
    Topic
  • #22708
    Resolved riderworks
    Participant

    Hi, This is a follow up to a previous ticket:#22643 that somehow got “Resolved”. I’m still having issues.

    I created a new CPT and Taxonomy and the “[object Object]” has not shown up in the PHP code.

    When I created a new CPT with v2.0.4, the “Supports” display Tab is blank. The default ‘supports’ = [‘title’, ‘editor’, ‘thumbnail’] shows, but I have no way to modify it.

    Two questions:

    When creating a taxonomy, do i have to add the taxonomy to the CPT AND add the CPT to the taxonomy?

    Also, how do I fix the current CPTs and Taxonomies. The CPTs still display “[object Object]”?

    I installed the “Query Monitor” plugin and it’s showing the following Warnings and Notices for the MB Custom Post Type plugin. See attached.

    https://www.dropbox.com/s/fzn9hazbcqhva5u/Screenshot%20of%20Brave%20Browser%20%2811-3-20%2C%208-42-45%20AM%29.png?dl=0

    Thanks.
    Doug

Viewing 1 replies (of 1 total)
  • Author
    Replies
  • #22714
    Long Nguyen
    Moderator

    Hi,

    Please update the new version of MB Custom Post Types & Custom Taxonomies v2.0.5, to fix the issue on the Support tab.

    When creating a taxonomy, do i have to add the taxonomy to the CPT AND add the CPT to the taxonomy?

    Because a post type can have multi taxonomies and a taxonomy can be assigned to multi post types so we have to add the taxonomy and post type back and forth.

    Also, how do I fix the current CPTs and Taxonomies. The CPTs still display “[object Object]”?

    For the current CPTs and Taxonomies, please delete and recreate with the same settings to remove the [object Object] code.

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.