Custom Fields
Re-Envisioned
Support Meta Box AIO Custom Post Type and Custom Field Type Unaccessible

This topic contains 7 replies, has 2 voices, and was last updated by  sean idle 6 months, 1 week ago.

  • Creator
    Topic
  • #13281

    sean idle
    Participant

    I was working along and out of nowhere one of my post types (on admin bar) said {{labels.menu_name}}. The post types’ posts are still discoverable, but the error is causing an inability to delete/edit post types (so I can’t just delete it). I am still able to create new ones though, but all posts within the post types do not show up saying “no your-post-type-here found” for “operational” post types and the broken one says {{labels.not_found}}.

    This did seem to occur after I enabled comments on the post type post creation. This error is affecting all operations of metabox because I can’t edit my custom fields either. I’ve been trying to find information as to where metabox keeps its data but have unsuccessful. I have checked my database, de and reactivated the plugin and deleted then reinstalled the plugins. There has also been no plugin changes and has never been any issues in the past.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Author
    Replies
  • #13296

    Anh Tran
    Keymaster

    Hi Sean,

    Can you edit the post type again (under Meta Box > Post Types) and make sure all labels are filled?

    #13301

    sean idle
    Participant

    No, this is isn’t possible. I can create a new one but it simply says there is none in that menu. It’s a very odd error. I also noticed today that even though I am able to query new posts created with the custom post type (I can create them but I cannot see them in the menu “your_custom_post_type”, just like with the post type menu), I am unable to access it from the internet.

    #13327

    Anh Tran
    Keymaster

    Do you see that post type in the table in the Meta Box > Post Types screen? Looks like that post type is broken and need to be fixed. If you see it, then please export it and send me.

    #13336

    sean idle
    Participant

    Sorry I don’t think I’m explaining well enough. The entire plugin is broken and I am unable to edit anything due to glitches not allowing me to do so. here are screenshots of how broken it is.

    https://drive.google.com/open?id=1RZ79FNdDuhG-CbnRiJigqC2p-_v10P7f

    Need this to be fixed ASAP. Like I said above, I’ve tried many troubleshooting steps and nothing has worked thus far.

    Thank you,
    Sean

    #13337

    sean idle
    Participant
    #13339

    Anh Tran
    Keymaster

    I see, can you please go to some tool like phpMyadmin and update the post type to mb-post-type, like in this screenshot: https://i.imgur.com/zzZ5KhL.png

    And also check for postmeta title, find the rows with post_id = your custom post type ID (in my screenshot above, it’s 126) and check + fix the meta value: https://i.imgur.com/TCT0OJz.png

    Sorry for this thing, I’m not sure why that happens. I saw this bug once, but now I can’t replicate it :(.

    #13343

    sean idle
    Participant

    Facepalm Thanks! I looked all over for my database and never bothered to try and search by post-type. In your “Database” section of documentation, it’d be a good idea to add that tag somewhere so that people no what they are searching for.

    Thanks again!
    Sean

Viewing 7 replies - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.