Custom Fields
Re-Envisioned
Support General Fatal Error after last update

  • Creator
    Topic
  • #29555
    chris@m11design.com
    Participant

    We have a couple of front-end forms so users can edit their custom fields. After the last update we are not getting a Fatal Error. Metabox AIO version 1.14.1 and Metabox version 5.4.6.

    One of the pages is : https://ecfunders.org/grantees/grantee-form/

    The error I'm getting is:

    Fatal error: Uncaught Error: Call to undefined function get_current_screen() in /home/ecfunders/public_html/wp-content/plugins/meta-box-aio/vendor/meta-box/mb-yoast-seo/class-mb-yoast-seo.php:21 Stack trace: #0 /home/ecfunders/public_html/wp-includes/class-wp-hook.php(292): MB_Yoast_SEO->enqueue(Object(RW_Meta_Box)) #1 /home/ecfunders/public_html/wp-includes/class-wp-hook.php(316): WP_Hook->apply_filters(NULL, Array) #2 /home/ecfunders/public_html/wp-includes/plugin.php(484): WP_Hook->do_action(Array) #3 /home/ecfunders/public_html/wp-content/plugins/meta-box/inc/meta-box.php(179): do_action('rwmb_enqueue_sc...', Object(RW_Meta_Box)) #4 /home/ecfunders/public_html/wp-content/plugins/meta-box-aio/vendor/meta-box/mb-frontend-submission/src/Form.php(82): RW_Meta_Box->enqueue() #5 /home/ecfunders/public_html/wp-content/plugins/meta-box-aio/vendor/meta-box/mb-frontend-submission/src/Shortcode.php(34): MBFS\Form->render() #6 /home/ecfunders/public_html/wp-includes/shortcodes.php(343): MBFS\Shortcode->shortcode(Array, '', 'mb_fr in /home/ecfunders/public_html/wp-content/plugins/meta-box-aio/vendor/meta-box/mb-yoast-seo/class-mb-yoast-seo.php on line 21

    Thank you your help.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Author
    Replies
  • #29559
    chris@m11design.com
    Participant

    I downgraded to version 1.13.8 (metabox-aio) on the site in question and everything works as it did before updating to 1.14.1. Perhaps there is something wrong in that new version.

    #29565
    Long Nguyen
    Moderator

    Hi Chris,

    I'm not able to reproduce the issue on my end. Please try to re-install Meta Box, MB AIO 1.14.1, and follow the Debugging Information step to see if it resolve the issue.
    https://metabox.io/support/topic/how-to-create-a-new-topic/

    #29569
    chris@m11design.com
    Participant

    Okay. I'll try to reinstall it. BTW - I did follow the debug procedures. The only thing that made it start working again was downgrading AIO to a previous version. Maybe reinstalling it will work.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.