Custom Fields
Re-Envisioned
Support Meta Box Builder Fatal error: Allowed memory size of # bytes exhausted

  • Creator
    Topic
  • #16937

    When trying to edit a custom Field Group I get the following error:

    Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 4198400 bytes) in hidden/wp-includes/functions.php on line 3737
    There has been a critical error on your website. Please check your site admin email inbox for instructions.
    
    Learn more about debugging in WordPress.

    Do you have any idea what could be the issue? I can still edit Post Types.

    MB Custom Post Type – Version 1.9.1
    Meta Box – Version 5.2.3
    Meta Box AIO Version – 1.10.7
    Meta Box for Yoast Seo – Version 1.3.5

Viewing 10 replies - 1 through 10 (of 16 total)
  • Author
    Replies
  • #16986
    Anh Tran
    Keymaster

    How many posts/terms do you have on the website?

    #17007

    wp_posts has 170889 rows
    wp_terms has 6167 rows

    #17085

    Any ideas on this? We can’t edit our custom fields until this is resolved and have changes to make.

    #17095
    Anh Tran
    Keymaster

    Hi, I’ve just pushed a new version of Meta Box Builder, which has a fix for this issue. Please update.

    #17099
    pza
    Participant

    After the latest update, also on a site with thousands of posts & taxonomies, editing or creating any field group in MB Builder is causing my browser to stall/crash

    #17129

    I just updated. I now have different issues. My browser does not stall/crash like pza’s, but when the Edit Field Group page loads:

    • my custom fields are not loaded (see screenshot)
    • the side menu of field types is styled incorrectly (see screenshot)
    • clicking on the “Settings” tab does nothing (does add a # to the url)
    • clicking on the “Code” tab works but the resulting page does not reflect my custom group’s data

    screenshot

    #17139
    Anh Tran
    Keymaster

    Hi Purdue, can you enable debug and see if there’s any error?

    #17150

    I enabled debug mode in wp-config.php, reloaded the page, and did not receive any errors.

    #17177
    Anh Tran
    Keymaster

    So strange. Do you see any JS error in the console?

    #17203
    pza
    Participant

    So I’m still assuming this is related to this topic (sorry if not) but I found the conflict in my case.

    • First I tried disabling all plugins except MB & MB AIO. I also tried changing to 2020 theme. My problem persisted: “Edit field group” window completely freezes and uses up 100% of CPU. No errors in the logs.

    With WP Debug on, I see only this warning

    Notice: Undefined index: taxonomy in /wp-content/plugins/meta-box-aio/vendor/meta-box/mb-custom-post-type/inc/taxonomy/register.php on line 113

    But this warning shows with MB AIO 1.10.7 as well, which does not freeze up.

    Next I started disabling AIO Extensions 1 by 1. The one that fixed it was disabling “Meta Box Include Exclude”. Then my “edit field group” loaded fine. It didnt matter which field group I’m editing (whether it’s using include/exclude or not).

    I’m just happy I know how to avoid it, as it was locking up my whole site. I hope this can help!

Viewing 10 replies - 1 through 10 (of 16 total)
  • You must be logged in to reply to this topic.