Custom Fields
Support MB Frontend Submission Frontend Form Dashboard Shortcode Broken

  • Creator
  • #19400
    Resolved Nicole


    I am trying to use the Dashboard shortcode described in your documentation for a frontend post. Unfortunately, the dashboard page is not properly linking to the edit page. Here is what I have setup:

    1. New Announcement - Page with the following shortcode: [mb_frontend_form id='announcements' post_fields="title,content" post_status="publish" submit_button="Publish" confirmation="Your announcement was successfully published!"]

      This page works properly and will create a new post as expected. The page id for this page is 3773.

    2. Manage Announcements - [mb_frontend_dashboard edit_page="3773"]
      Despite having created posts using the page "New Announcements" this dashboard page always shows "You have 0 posts. Add New You currently have no posts." When I click the "Add New" part of the text on this page it takes me to the correct "New Announcement" page.

    Am I missing a setting to get this working? I have tried disabling plugins and that doesn't seem to help.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Author
  • #19408
    Long Nguyen


    I've checked the shortcode to manage the submitted post and it works as well, please take a look at a short screen record

    Could you please deactivate all plugins except Meta Box plugins then try to submit a post with your user logged in and check again? And make sure that you are using the latest version of MB Frontend Submission v2.2.1.


    I have a similar problem, I don't know if it can be useful to solve both: I have noticed that the page with the list of posts is that of the post type "Posts", while my form writes in the post type "feedback". I have tried in many ways, but the list always shows the Posts

    Long Nguyen

    Hi Marcodedo,

    Please set the post type attribute of the shortcode Frontend Submission to edit the post type in the post dashboard

    [mb_frontend_form id='meta-box-id' post_fields='title, content' post_type='feedback']

    For further information, please follow the documentation


    Yes, now works. Thank you.


    Yay! That was all I needed, to add post type, and it worked for me.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.