Custom Fields
Re-Envisioned
Support MB Custom Post Type MB Custom Post Types CPT missing and error logs

  • Creator
    Topic
  • #22699
    Resolved Max Elman
    Participant

    Hi,

    Today I found out that one of my CPTs was broken, nothing was being displayed. I had to create a new CPT with another name and move the posts there. The CPT slug was "videos", I don't know if that matters.

    The CPT is working now, but the plugin MB Custom Post Types & Custom Taxonomies is not. And the CPT icon isn't showing up either. If I try to edit one of my CPTs and go to the Supports tab, everything disappears: https://rzfg.co/LRkE14

    While troubleshooting on staging, I found out that as soon as I activate MB Custom Post Types & Custom Taxonomies, I get this error:

    2020/11/03 23:48:16 [error] 3620#3620: *379 FastCGI sent in stderr: "PHP message: PHP Warning: strpos() expects parameter 1 to be string, array given in /www/proterra_543/public/wp-includes/media.php on line 3446" while reading response header from upstream, client: 45.70.235.84, server: staging-proterra.temp513.kinsta.cloud, request: "GET /wp-admin/plugins.php?activate=true&plugin_status=all&paged=1&s= HTTP/1.0", upstream: "fastcgi://unix:/var/run/php7.3-fpm-proterra.sock:", host: "staging-proterra.temp513.kinsta.cloud", referrer: "https://staging-proterra.temp513.kinsta.cloud/wp-admin/plugins.php"

    I also get very similar errors whenever I do anything else on the site, like updating any post or activating/deactivating other plugins. But that only happens when the MB Custom Post Types & Custom Taxonomies is active.

    Any idea why that is happening?

Viewing 2 replies - 11 through 12 (of 12 total)
  • Author
    Replies
  • #22778
    Long Nguyen
    Moderator

    Hi,

    Something went wrong with the post type slug video, I just change to my-video and save permalink settings again to make it works. Check on this link https://staging-proterra.temp513.kinsta.cloud/my-video/test-my-video/.

    #22789
    Max Elman
    Participant

    Yes - we figured that out a few days ago. We'd like to use that slug name. Do you know what is the problem with using "video"? Thank you!

Viewing 2 replies - 11 through 12 (of 12 total)
  • You must be logged in to reply to this topic.