Custom Fields
Re-Envisioned
Support MB Blocks Some field types are not displayed within the block

  • Creator
    Topic
  • #15703
    Resolved Content Pilot
    Participant

    Hi Anh, I’m trying with the new extension and I’m having a problem with some fields types.
    The fields below work outside the block but not inside.

    $meta_boxes[] = array(
        'title'    => 'Slider',
        'id'       => 'slider',
        'type'     => 'block',
        'icon'     => 'admin-home',
        'category' => 'layout',
        'context'  => 'side',
        'supports' => array(),
        'fields'   => array(
            array(
                'id'   => 'color',
                'name' => 'Color',
                'type' => 'color',
            ),
            array(
                'id'   => 'image',
                'type' => 'image_advanced',
                'name' => 'Image Advanced',
            ),
            array(
                'id'   => 'video',
                'type' => 'video',
                'name' => 'Video',
            ),
        ),
    );

    View post on imgur.com

    Can you tell me if I am doing something wrong?
    Thanks

Viewing 7 replies - 1 through 7 (of 7 total)
  • Author
    Replies
  • #15708
    Content Pilot
    Participant

    Update: If the fields are within a clonable group, the first item is not displayed correctly, as of the second, yes. Still, the values are not saved.

    View post on imgur.com

    #15710
    Anh Tran
    Keymaster

    Hi,

    Are you using the AIO plugin or MB Blocks plugin individually? I fixed this bug in MB Blocks, but haven’t deployed to API yet.

    #15716
    Content Pilot
    Participant

    Thanks for your reply Anh,

    I was trying with the API. Now I tried it with plugin v1.0.3 and the same thing happens, the fields are not shown and the values are not saved. Note: if I add the fields within a clonable group, from the second they are displayed.

    #15718
    Anh Tran
    Keymaster

    Hi, I’ve tested with your code and it works. Please see my video: https://www.loom.com/share/b104b120c7d64513a7b7a1e10f605949

    Please try clear the browser cache and try again. I guess some scripts are missing. Please check the console as well.

    #15761
    SAS
    Participant

    Hi Anh,

    unfortunately, some fields are still not displayed correctly. E.g. “Images” and “Colors”. Also, “Button Group” is not saved correctly. If I choose something and save the page, the selected button is still checked, but if I reload the page, the selected button is no longer selected.

    We use the latest version 1.0.4 and MB Blocks plugin individually.

    Can you help?

    #15774
    Anh Tran
    Keymaster

    Can you please send me a temporary admin account to check the problem? I need to debug to see what’s wrong with your site.

    #15861
    Content Pilot
    Participant

    Thanks Anh, the problem was that I was not getting one of the latest versions of metabox that is necessary since you have made important JavaScript changes for MB Blocks.

    For me it’s fine if we close the ticket.
    Thanks for your help

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.