Custom Fields
Re-Envisioned
Support General Updating MetaBox with extensions through composer

This topic contains 4 replies, has 2 voices, and was last updated by  ComSi 3 days, 4 hours ago.

  • Creator
    Topic
  • #11588
    Resolved
    ComSi
    Participant

    Hi Anh,

    We’re using MetaBox with extensions through composer. But i can’t update it. Were using the following composer.json file:

    
    {
        "name": ".../...",
        "authors": [
            {
                "name": "ComSi",
                "email": "..."
            }
        ],
        "repositories":[
            {
            "type": "composer",
            "url": "https://wpackagist.org"
            },
            {
            "type": "composer",
            "url": "https://packages.metabox.io/{OUR_META_BOX_KEY}"
            }
        ],
        "require": {
            "wpackagist-plugin/meta-box": "dev-trunk",
            "meta-box/meta-box-conditional-logic": "dev-master",
            "meta-box/meta-box-group": "dev-master"
        },
        "extra": {
            "installer-paths": {
                "vendor/meta-box/meta-box/": ["wpackagist-plugin/meta-box"],
                "vendor/meta-box/meta-box-group/": ["meta-box/meta-box-group"],
                "vendor/meta-box/meta-box-conditional-logic/": ["meta-box/meta-box-conditional-logic"]
            }
        },
        "autoload": {
            "files": [
                "vendor/meta-box/meta-box/meta-box.php",
                "vendor/meta-box/meta-box-group/meta-box-group.php",
                "vendor/meta-box/meta-box-conditional-logic/meta-box-conditional-logic.php"
            ]
        }
    }
    

    Is it possible to not use the dev-trunk and dev-master, but just the newest versions? I tried to set the “dev-trunk” to “4.*” but then i’m receiving the following error.

    
    - Updating wpackagist-plugin/meta-box (dev-trunk => 4.19.10):  Checking out tags/4.19.10
    Update failed (Package could not be downloaded,
    'svn' is not recognized as an internal or external command,
    operable program or batch file.
    

    Thanks in advance.
    ComSi Websupport (Erik-Jan)

Viewing 4 replies - 1 through 4 (of 4 total)
  • Author
    Replies
  • #11598

    Anh Tran
    Keymaster

    Hi Erik,

    The error comes from the version dev-trunk for meta-box package (the free one). Please specify a correct version like ^4.15. There was an error in the tags in SVN for version “4.19.10” (which is not available. It should be “4.14.10”). I’ll fix that now.

    #11599

    ComSi
    Participant

    Hi Anh,

    Thanks for the reply but it doesnt work. I tried what you said, and changed the dev-trunk for meta-box (free version) to ^4.15 and runned composer update.

    My require element look like this:

    
    "require": {
        "wpackagist-plugin/meta-box": "^4.15",
        "meta-box/meta-box-conditional-logic": "dev-master",
        "meta-box/meta-box-group": "dev-master"
    }
    

    Again the same error:

    
    C:\{MY_PATH}>composer update
    Loading composer repositories with package information
    Updating dependencies (including require-dev)
    Package operations: 0 installs, 1 update, 0 removals
      - Updating wpackagist-plugin/meta-box (dev-trunk => 4.19.10):  Checking out tags/4.19.10
        Update failed (Package could not be downloaded,
    'svn' is not recognized as an internal or external command,
    operable program or batch file.
    )
        Would you like to try reinstalling the package instead [yes]?
    
    #11600

    Anh Tran
    Keymaster

    Please do not use composer update. Try to remove the vendor folder and do composer install again. Running update makes Composer look up for a higher version than the current 4.19.10, which is not available.

    #11606

    ComSi
    Participant

    Thanks, just updated it through your suggestion. Work like a charm. Thanks!

Viewing 4 replies - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.