Custom Fields
Re-Envisioned
Support Meta Box Conditional Logic WordPress 5.6.x Conditional Logic issues :hidden

Viewing 5 replies - 1 through 5 (of 5 total)
  • Author
    Replies
  • #24606
    Austin Passy
    Participant

    I see the following console log (warning):
    JQMIGRATE: jQuery.isNumeric() is deprecated jquery-migrate.js:100:12
    console.trace() jquery-migrate.js:102:13
    jQuery 2
    isLogicCorrect https://.../wp-content/plugins/meta-box-aio/vendor/meta-box/meta-box-conditional-logic/conditional-logic.js?ver=1.5:279
    isLogicCorrect https://.../wp-content/plugins/meta-box-aio/vendor/meta-box/meta-box-conditional-logic/conditional-logic.js?ver=1.5:224
    runConditionalLogic https://...wp-content/plugins/meta-box-aio/vendor/meta-box/meta-box-conditional-logic/conditional-logic.js?ver=1.5:182
    jQuery 2
    runConditionalLogic https://.../wp-content/plugins/meta-box-aio/vendor/meta-box/meta-box-conditional-logic/conditional-logic.js?ver=1.5:177
    <anonymous> https://.../wp-content/plugins/meta-box-aio/vendor/meta-box/meta-box-conditional-logic/conditional-logic.js?ver=1.5:595
    jQuery 9
    <anonymous> https://.../wp-content/plugins/meta-box-aio/vendor/meta-box/meta-box-conditional-logic/conditional-logic.js?ver=1.5:594
    <anonymous> https:/.../wp-content/plugins/meta-box-aio/vendor/meta-box/meta-box-conditional-logic/conditional-logic.js?ver=1.5:604
    <code></code>

    #24616
    Long Nguyen
    Moderator

    Hi,

    I've tested to run your code on my local site but not see any issue. Screen record https://share.getcloudapp.com/ApuRDAdR.

    Look at your screen record, I do not see the error text "This field is required." under the empty field.

    Can you please re-test your case in a fresh install of WordPress and Meta Box?

    #24653
    Austin Passy
    Participant

    I can confirm it's an issue with WordPress 5.6 with Polylang PRO installed. Still unclear as to the underlying issue. Will confirm as I know more in the coming weeks.

    #24856
    Austin Passy
    Participant

    I have tracked down the underlying issue. In WordPress 5.6 (as mentioned above in the steps where it's broken vs working) having a hidden wysiwyg field blocks the publication when that field type is set to required as post meta. Until I toggle the option that shows the wysiwyg and then re-hides it will unblock the validation of required blocker.

    Let me try to get a video attached and follow up if it would help. I will also try to see what might have changed from core WP 5.5.x to 5.6.x with the wp_editor.

    Thanks.

    #24857
    Austin Passy
    Participant

    Video walk through (expires in 7 days): https://webmshare.com/rVW6x

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.