To increase the compatibility and easily develop new extensions for Meta Box, we have implemented the major version 5.0.0. This version has a number of major changes and may not be backward compatible. In case you see any problem, please let us know or roll back to an older version.

Minimum Required PHP Version 5.3

WordPress has raised the minimum required PHP version from 5.2 to 5.6 earlier this year. However, this is just a soft requirement, since most of the features will work without any problem in PHP 5.2.

Meta Box used to support PHP 5.2, until now. And the change is a strict requirement. If your host still uses PHP 5.2, Meta Box won't work and your site will be broken.

Why Higher PHP Version?

PHP 5.3 or any later PHP version helps us making the code better, cleaner and shorter. Thus, increase the maintainability and performance. These are some features from PHP 5.3 that we are using or will use:

  • Autoload (which can't be disabled)
  • Namespace
  • Late static binding

The WordPress stats page shows that PHP 5.2 is used on less than 2%. So, we think, it's quite safe to update the requirement now.

What If I Can't Upgrade PHP To 5.3+?

First, please try to contact your hosting provider for help. Most of the hosting providers can help you upgrade to PHP 7. The latest stable version of PHP is now 7.3. If they don't upgrade, we suggest changing the host. There are a lot of good hosting providers out there.

Another solution is just using an older version of Meta Box (the latest stable version which supports 5.2 is 4.18.4). You can download an older version here.

Why Not PHP 7?

We'd love to! There's nothing better if you're using PHP 7. The performance is twice than PHP 5!

Meta Box increased the minimum required PHP version to PHP 7

But as the stats page shows, the number of users using PHP version older than 5.6 is 15.4%, and PHP 5.6 is 29.3%! We hope with the help of Site Health project, more hosts will upgrade the PHP.

In the future, we might increase the minimum required PHP version if we need a feature from it. But for now, PHP 5.3 is enough.

Auto Update For Premium Extensions

Previously, in order to update the premium extensions, you need to install an individual extension - Meta Box Updater. In this update, we have included the updater into the Meta Box plugin, so you don't have to install another plugin anymore. That might help cleaning up your plugin list a little bit!

And if you don't have any premium extension installed, you won't notice any change in Meta Box (no admin menu, no notification, etc.). Everything is still the same as before.

Ready For Creating Gutenberg Blocks

This update also prepares for the next premium extension MB Blocks, which will be released next week. The extension will allow you to create Gutenberg blocks using PHP only. No JavaScript build process, no Webpack, Babel or similar thing. And the syntax is still beautiful and clean, just like a normal meta box.

We've been working on this for months and we're very excited about that. We'll show you a tutorial later about this. Stay tuned!

Backward Compatibility Sounds Scary! How Do I Know If My Website Is Compatible?

The backward compatibility means the PHP 5.2 version and backward. If you're using PHP ≥ 5.3, everything is fine.

If you develop plugins or themes that use Meta Box, it's still safe. All the API, public functions remain the same as in previous version.

Leave a Reply

Your email address will not be published. Required fields are marked *